Results 1 to 2 of 2

Thread: BT5 for ARM on Plug Computer (Sheeva or Guru)

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Jul 2011

    Default BT5 for ARM on Plug Computer (Sheeva or Guru)

    The GuruPlug Plus uses a Marvell Kirkwood 6281A1, 1.2GHz processor and the Sheeva runs a 1.2 GHz Marvell Kirkwood 6281. The former is billed as an "ARM-compatible CPU (aka Feroceon)".

    I am trying to install BT5 ARM on both the Sheeva and Guru Plus (just for jollys) but can anyone see any reason why it will *certainly* fail on either of these two processors? I haven't invested much time in doing this yet, and before I actually start to care it would be good to know if it is outright futile.

    Thanks for any thoughts. Naturally I will post any positive results.

  2. #2
    Just burned his ISO bungfish's Avatar
    Join Date
    Sep 2010

    Default Re: BT5 for ARM on Plug Computer (Sheeva or Guru)

    Hopefully this will help someone wanting to go down this path. I've got a grey CloudEngines Pogoplug v2 (based on the Sheeva Plug hardware plus it has 4 USBv2 ports) that I've tried to get running with Backtrack v5 ARM. Armed with a USB flash drive and 3 WiFi adapters, it could be a nice poor man's portable exploitation kit. I used the instructions online to "jailbreak" it and install Arch Linux ARM on a flash drive. Arch Linux for ARM has a lot of tools in its repositories (including kismet which I got to work). I was initially encouraged because the included busybox binary ran on the Pogoplug. Other programs would cause segmentation faults or missing dependency errors. I tried mounting the image and copying the contents to another flash drive but since there is no kernel on the image, my copy wouldn't boot. I tried mounting the image and running programs straight from the image but the executables and config files are assuming an execution root of / and not /mnt/bt5/. So I tried to mount the BT5 image and chroot to it but chroot results in a segmentation fault. I tried to install ruby from the Arch Linux repositories (for metasploit) but it doesn't work (I forgot why). Now I think there are too many architectural differences between the Pogoplug hardware (ARMv5) and the programs on the BT5 image (compiled for ARMv7) for the programs to be used directly (source: Raspberry Pi thread I was trying to get a copy of the source code so I could compile my own version of backtrack for ARMv5 but I can't find where the source code is hosted (the location doesn't seem to be posted in the forums or on the web site). Even if I find the source, compiling everything and patching the kernel and wireless drivers will prove a challenge. If anyone knows where the source code it hosted, please drop me a line. Let me know if you make any progress. good luck!

Similar Threads

  1. 20 pin ATX plug & pins
    By Re@lity in forum OLD General IT Discussion
    Replies: 3
    Last Post: 06-06-2009, 07:18 PM
  2. MS-DOS Guru's Only
    By imported_DragonKnight in forum OLD General IT Discussion
    Replies: 2
    Last Post: 03-03-2009, 11:05 PM
  3. after unplug and plug usb, /dev/sd* is changed!
    By muzehyun in forum OLD Newbie Area
    Replies: 4
    Last Post: 02-03-2009, 12:45 PM
  4. Realplayer Plug-in
    By The_Denv in forum OLD Feature requests
    Replies: 2
    Last Post: 01-17-2008, 05:13 PM
  5. BT freeze after plug USB mouse
    By g00dca7 in forum OLD Newbie Area
    Replies: 0
    Last Post: 07-26-2007, 08:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts