Hello Forum, I have spent around 5 day's trying to get my wireless card to work. It worked when I initially installed backtrack, but after I installed Cuda and upgraded the distrobution I have not been able to Even see the wireless card. I am running off of a xps computer and I have tried many things with much failure.
I have tried using the linux and xp drivers, but that has not gone so well. Here is the linux driver
With that when compiliing the make file this occured
make[1]: Entering directory `/usr/src/linux-source-2.6.38'

WARNING: Symbol version dump /usr/src/linux-source-2.6.38/Module.symvers
is missing; modules will have no dependencies and modversions.

CC [M] /root/rtl8192u_linux_2.6.0006.1031.2008/ieee80211/ieee80211_rx.o
CC [M] /root/rtl8192u_linux_2.6.0006.1031.2008/ieee80211/ieee80211_softmac.o
CC [M] /root/rtl8192u_linux_2.6.0006.1031.2008/ieee80211/ieee80211_tx.o
CC [M] /root/rtl8192u_linux_2.6.0006.1031.2008/ieee80211/ieee80211_wx.o
/root/rtl8192u_linux_2.6.0006.1031.2008/ieee80211/ieee80211_wx.c: In function ‘ieee80211_wx_get_encode_ext_rsl’:
/root/rtl8192u_linux_2.6.0006.1031.2008/ieee80211/ieee80211_wx.c:846: warning: suggest parentheses around operand of ‘!’ or change ‘&’ to ‘&&’ or ‘!’ to ‘~’
CC [M] /root/rtl8192u_linux_2.6.0006.1031.2008/ieee80211/ieee80211_module.o
/root/rtl8192u_linux_2.6.0006.1031.2008/ieee80211/ieee80211_module.c: In function ‘alloc_ieee80211_rsl’:
/root/rtl8192u_linux_2.6.0006.1031.2008/ieee80211/ieee80211_module.c:121: error: ‘struct net_device’ has no member named ‘hard_start_xmit’
make[2]: *** [/root/rtl8192u_linux_2.6.0006.1031.2008/ieee80211/ieee80211_module.o] Error 1
make[1]: *** [_module_/root/rtl8192u_linux_2.6.0006.1031.2008/ieee80211] Error 2
make[1]: Leaving directory `/usr/src/linux-source-2.6.38'
make: *** [all] Error 2

I also tried using ndiswrapper for the xp service pack 2 driver
these three files
net8192su.cat net8192su.inf rtl8192su.sys

And here was the output
It installed

Then I listed them

net8192su : driver installed
device (07D1:3300) present (alternate driver: r8712u)

But then I tried airmon-ng and here was the output

Interface Chipset Driver

and Ifconfig

eth0 Link encap:Ethernet HWaddr 00:1e:4f:bd:54:d8
inet addr: Bcast: Mask:
inet6 addr: fe80::21e:4fff:febd:54d8/64 Scope:Link
RX packets:9001 errors:0 dropped:0 overruns:0 frame:0
TX packets:8462 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:8813134 (8.8 MB) TX bytes:1548093 (1.5 MB)

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:612 errors:0 dropped:0 overruns:0 frame:0
TX packets:612 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:89815 (89.8 KB) TX bytes:89815 (89.8 KB)

wlan0 Link encap:Ethernet HWaddr 14:d6:4d:16:55:22
RX packets:416335 errors:0 dropped:1490 overruns:0 frame:0
TX packets:224280 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:624060445 (624.0 MB) TX bytes:20308811 (20.3 MB)

lshw -C network
PCI (sysfs)

description: Ethernet interface
product: NetXtreme BCM5754 Gigabit Ethernet PCI Express
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:05:00.0
logical name: eth0
version: 02
serial: 00:1e:4f:bd:54:d8
size: 100MB/s
capacity: 1GB/s
width: 64 bits
clock: 33MHz
capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.116 duplex=full firmware=5754-v3.22 ip= latency=0 link=yes multicast=yes port=twisted pair speed=100MB/s
resources: irq:45 memory:dbef0000-dbefffff
description: Wireless interface
physical id: 1
bus info: usb@1:7
logical name: wlan0
serial: 14:d6:4d:16:55:22
capabilities: ethernet physical wireless
configuration: broadcast=yes driver=r8712u multicast=yes wireless=unassociated

Then this

iwlist scan

lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wlan0 Failed to read scan data : Invalid argument

iwlist wlan0 scan

wlan0 Failed to read scan data : Invalid argument

than with lsub it says

Bus 002 Device 004: ID 0461:4d15 Primax Electronics, Ltd Dell Optical Mouse
Bus 002 Device 003: ID 413c:2003 Dell Computer Corp. Keyboard
Bus 002 Device 002: ID 0556:0001 Asahi Kasei Microsystems Co., Ltd AK5370 I/F A/D Converter
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 07d1:3300 D-Link System
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

bolded is the usb hub.

Any suggestion to get the wicd manager recognize it? Any advice would be appreciated.