As the title states ettercap has disappeared on me, I don't know if i installed a package that stripped it away or whats going on but when I tried to download it from the repos again I get a 404 error

# apt-get install ettercap
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
The following NEW packages will be installed:
  ettercap ettercap-common
0 upgraded, 2 newly installed, 0 to remove and 4 not upgraded.
Need to get 517kB of archives.
After this operation, 1,716kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Err revolution/main ettercap-common 1:0.7.3-1.4ubuntu1
  404  Not Found
Err revolution/main ettercap 1:0.7.3-1.4ubuntu1
  404  Not Found
Failed to fetch  404  Not Found
Failed to fetch  404  Not Found
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
I did run apt-get update and then I tried apt-get install ettercap --fix-missing and still got the 404 error.

I noticed this same problem has been occurring with other people in the update-script thread, but I've personally never used that script.

Does this have anything to do with the latest version of ettercap being released?