Results 1 to 6 of 6

Thread: WICD Error (Yes another one)

  1. #1
    Just burned his ISO
    Join Date
    Mar 2008

    Default WICD Error (Yes another one)

    Ok so after downloading Backtrack 5 KDE 32-bit version i installed it to a DVD and ran it as a LiveCD. It worked perfectly, connected using WICD perfectly. Then i installed it to my HD to run a dual boot win7/BT5. After doing this i got the "cannot connect do d-bus" error which i fixed and it connected again perfectly. I installed some drivers for my system (ATI Catalyst Drivers) and a couple other small things that should not effect the system much. Well i had restarted my computer a few times through all of these processes and everything connected so i assumed everything was alright. I shutdown for the night using "Shutdown -P 1" and went to bed. I woke up the next morning and started the system up again and came across the "Bad Password" issue. After spending the rest of last week reading "fixes" to this issue and reinstalling backtracks about 3 times...nothing worked. I removed network-manager, i reconfigured wicd etc. There were about 7 different "fixes" to this issue that i've tried. Finally i came across an article that basically instructed me to force-downgrade WICD to version 1.6.1 instead of 1.7. After doing this i got past the Authentication issues and no longer received the Bad Password error. Now instead i get "Unable to get IP Address" after wicd takes about 5 minutes to get past validation and into obtaining IP address phase. I am about to test and see if GNOME gives me the same problem ( I'm kind of new to Linux so really this is just a guess).

    Does anyone have any idea what is causing this issue? The current wireless card that I am using is a D-Link DWA-552, the AP is a D-Link DIR-655 Xtreme-N router.

  2. #2
    Moderator KMDave's Avatar
    Join Date
    Jan 2010

    Default Re: WICD Error (Yes another one)

    You could try out the command line in order to connect to your wireless lan and see if that is working or if it is resulting in any error message.
    Tiocfaidh ár lá

  3. #3
    Just burned his ISO
    Join Date
    Mar 2008

    Default Re: WICD Error (Yes another one)

    Hey, sorry for the long time between responses. Got really frustrated with BT5 and took a long break lol. I tried to connect to wireless through cmdline and got an error! When i typed

    iwconfig wlan0 key xxxxxxxxxx
    i get: Error for wireless request Set Encode (8b2A). I tried to figure it out a bit but its a little beyond my abilities for linux =/

  4. #4
    Just burned his ISO gandaran's Avatar
    Join Date
    Jun 2011

    Default Re: WICD Error (Yes another one)

    how did you fix the "cannot connect do d-bus" error? I get the same error starting WICD but WICD still works fine every-time,I have searched for a solution on the forum but haven't found one.
    Sorry if this isn't helping you fix your problem but I can only ask do you know if your wireless device is supported? drivers installed?
    Post the output of "lsusb" and "lspci" then we can check if you need to install drivers.

  5. #5
    Just burned his ISO
    Join Date
    Jul 2011

    Default Re: WICD Error (Yes another one)

    The solution for the D-Bus error is on the Backtrack wiki. Check Getting started -> Basic usage.

  6. #6
    Just burned his ISO
    Join Date
    Jun 2012
    Paciific Ring of Fire

    Wink Re: WICD Error (Yes another one)

    This is exactly what im going through right now, and for the past 3 days.
    I also went through this kind of hell, and until this moment, and still with no luck at all.
    still in hope, that i could make through this one ALIVE!
    googling . . . researching. . . asking questions around the universe.

    wandering the harsh desserts of the digital world. =)

    Im checking this one out later, hope it'll do the trick. Im still on windows right now. and kinda busy at the moment helping my friend on the line about windows 'problems'.

Similar Threads

  1. Strange Wusb54g Error On Wicd
    By studlymidget in forum Beginners Forum
    Replies: 0
    Last Post: 01-29-2011, 03:05 PM
  2. WICD error when start !
    By Smoker in forum Beginners Forum
    Replies: 2
    Last Post: 09-04-2010, 06:02 AM
  3. wicd D-Bus error
    By Mr-Protocol in forum Beginners Forum
    Replies: 6
    Last Post: 08-01-2010, 12:20 AM
  4. Python error - WICD - wpa dont connect
    By nitroglico in forum Beginners Forum
    Replies: 2
    Last Post: 04-14-2010, 12:59 AM
  5. wicd-client + Forensics Mode Error
    By jtesta in forum OLD BackTrack 4 Bugs and Fixes
    Replies: 4
    Last Post: 06-21-2009, 12:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts