Hey all,

I've got BT5 (GNOME)installed on my VM at the moment for several testings to make certain wether i'll make it my Prime OS or not and i'm having some issues that i'm not sure where to turn to with.
for the record - i've looked in ubuntu forums and google for answers but none helped so i'm hoping here will find salvation.

issue 1:
Tried installing Compiz fusion, emerald and the rest of them packages. download completed successfully & seems to be installed fine but i can't run any of the features.
Is it caused by the fact this is on VM? or there's a known issue with BT5 and compiz fusion?

Issue 2:
I've got issues with connecting my Atheros 4321(TPlink dongle) card with WPA2 PASSPHRASEs longer than 8 "letters"(forgive my poor english). i've read somewhere that it's a known issue between this chipset and WPA2 , but i thought i'll check here first: anyone knows about it? maybe there's a solution for it?(other than shortening the passphrase).

Issue 3:
I keep failing on installing VirtualBox 4.0(or any other version for the record). I've looked the errors up in google and ubuntu forums and found help but none actually worked.

Anyone had issues with Virtualbox installation on BT5 Gnome? or on a VM?