Results 1 to 7 of 7

Thread: Do USB GPS devices work on BT2?

  1. #1
    Junior Member
    Join Date
    Jun 2006

    Talking Do USB GPS devices work on BT2?

    I just purchased a Holux Sirf Star III GR-213U USB GPS device and followed all the instructions from here but nothing. I even used the gspdold from netstumbler but even that makes the device always read 0's in kismet and still nothing. Even configured kismet to use the gps lock as it states this fixes the constant 0's problem still nothing.

    The device installs and links it to /dev/tts/USB0

    The gpsd wesbite says this device is fully compatible with the daemon.

    Any ideas?

  2. #2
    Senior Member PrairieFire's Avatar
    Join Date
    Apr 2007


    I use this for my USB Holux
    gpsdold -p /dev/ttyUSB0 -D 3 -s 19200 -K
    Using -D >2 should keep gpsdold running in that terminal allowing you to see problems if any.

  3. #3
    Join Date
    Jan 2007


    What happens when you use netcat to connect to the port gpsd is running on? After connecting, hit enter.

    Some people have had better luck with the newest version available at

    Have you read the gpsd manual page?

  4. #4
    Moderator theprez98's Avatar
    Join Date
    Jan 2010


    I use the Sirf Star USB GPS that came with Microsoft Streets and Trips 2007. It works fine.

    If you used the newer version of gpsd, and then tried to use gpsdold, you may need to boot into Windows, use the Sirf Star utility program that came with the GPS, and make sure to reset all the defaults. The buggy gpsd changes some settings that will cause the GPS problems without resetting it.

  5. #5
    Junior Member
    Join Date
    Jun 2006


    Thanks everyone. I'm very happy that someone in here is using the holux it as well. I'm installing right now on my windows box to verify the device works (just got it off ebay) and to reset the settings.

    I did update the gpsd to the latest version 2.3.4. I'll post back here with my results.

  6. #6
    Junior Member
    Join Date
    Jun 2006

    Talking Victory!!!!!!!!!!!!!

    Here are the golden statements:

    killall gpsd
    mknod /dev/ttyUSB0 c 188 0
    gpsd -n /dev/ttyUSB0

    This tapped right into the software and the system started spitting out the firmware info, etc.

    Now I did take your advice prez and I reset the device prior to this in windows and I added the checkmarks from their ULTRA CRAPPY gpsviewer software.

    I did boot up kismet right after and it works. TO KNOW IT WORKS you should see writing above the status window near the bottom that says something like this:

    Lat 23.345 Lon -56.345 Alt 345.56 Spd 1.1744m/h Hed 42.619 Fix 3D.

    If its not working you'll either see all 0's OR the FIX column will say no signal. As far as the 0's go there is an option within the kismet.conf file to enable gps lock. Set that to true instead of false then retry it again.

    A WORD OF ADVICE: When testing it from kismet run it from the command line not the shortcut in the kde menu. Reason being it will quickly shutdown and close the terminal windows it starts up in. There is vital information in there regarding your gps.

    I'll post back a few maps and the programs I have used.

    Just when your about to throw the box + device your configuring out the window, it all comes together. LOL I've been in that situation way too many times.

  7. #7
    Just burned his ISO
    Join Date
    May 2007

    Default gpsd in Backtrack 2 final

    I was having a problem with gpsd working in Backtrack 2 final and found out is was an old version.

    gpsd -V said it was gpsd version 2.33 and I think you need version 2.34.

    I had to create an lzm file and add it to the BT/modules/ so it would be installed on the liveCD version. I tried to attach the lzm file that I created to the post but the system wouldn't let me. You can try creating a lzm of gpsd 2.34 by downloading gpsd 2.34 and following the instructions in the link.

    I guess I don't post enough. I can't post the URL either because I haven't posted 15 posts yet. Try googling for "backtrack lzm" that is how I found the instructions.

    Hope this helps!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts