Results 1 to 3 of 3

Thread: remastersys changed my login

  1. #1
    Join Date
    Nov 2008

    Default remastersys changed my login

    Was using backtrack5 on a hard drive. made some changes (like adding remastersys!) and did a backup(using remastersys). replaced my current version of backtrack5 on a usb stick.
    Boots into command line with

    I used to be root#

    What happened?

    tried login root and got

    Cannot possibly login as root without user

    So, I asked the author of remastersys what's up and he said:

    The backtrack folks must do something different than ubuntu. When you remaster, you are remastering like ubuntu and it appears the backtrack devs do something different.
    The ubuntu live scripts called casper basically disable the root account during live boot.
    If you can find out from the backtrack folks what they have done differently I might be able to do something about it.


  2. #2
    Senior Member
    Join Date
    May 2010

    Default Re: remastersys changed my login

    My root account works fine with the default remastersys rebuild. The only difference was the login screen which I will have to do extra work to get grub to load in the original manner. They definitely did something different.
    Last edited by Scamentology; 06-30-2011 at 03:58 PM.
    "Never do anything against conscience -- even if the state demands it."
    -- Albert Einstein

  3. #3
    Just burned his ISO
    Join Date
    May 2011

    Default Re: remastersys changed my login

    I hope I am not stating the obvious or attempting to be insulting but here are the steps I used to configure Remastersys' graphical user interface:

    1. Launch the "Remastersys Backup" utility.
    2. Highlight "Modify" and click "OK."
    3. Highlight "a" to modify the default "Username." Enter "root" without the quotes and click "OK"
    4. Run Remastersys to create a distro or backup.

    This will result in the root configuration being default (vice Remastersys' "custom" user which doesn't exist in BT5). You will have to login using "root" and "toor" for the userid and password before you get a root prompt and can run the startx command.

    Honestly, I knew Remastersys would want to add its bootloader configuration (splash screen and /isolinux/syslinux.cfg files differ from BackTrack's). I just used an .iso editor and copied over the beautiful BT5 splash.png and syslinux.cfg files found in the original BT5 iso file into my newly remastered iso file's /syslinux directory overwriting the old ones. Problem solved for me. Sounds awkward but it works nicely.

    Have an OUTSTANDING day!
    Last edited by qhent; 07-01-2011 at 03:26 PM.

Similar Threads

  1. (help) my kde changed to gnome
    By ~vinblack~ in forum Beginners Forum
    Replies: 0
    Last Post: 05-17-2010, 06:56 PM
  2. Can't authenticate any more - what's changed?!
    By RakeSnake in forum Beginners Forum
    Replies: 4
    Last Post: 04-15-2010, 08:19 AM
  3. 2.6.32.x and remastersys?
    By RageLtMan in forum Beginners Forum
    Replies: 7
    Last Post: 02-21-2010, 03:04 AM
  4. Icons changed on me......
    By squishyalt in forum OLD BT3beta General
    Replies: 5
    Last Post: 06-07-2008, 07:59 AM
  5. I've changed laptop. And now?
    By AmphybiouS in forum OLD Wireless
    Replies: 31
    Last Post: 11-08-2007, 03:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts