Hi guys,

I'm trying to run backtrack5 - Gnome - 64bit on an usb stick with persistence, and I am having a lot of problems. I've already had to format and reinstall at least 15 times, but always I run into problems after a while. Some of them seem to happen when I try to update. Let me be more specific. First of all, I use the tutorial posted here on running BT5 + Metasploit + PostgreSQL. It works fine, but after I restart, when backtrack boots, even before I do startx I keep getting the error

EXT2-fs loop1 deleted inode referenced

if I uninstall postgresql then this error disappears. But I don't understand what's postgresql even got to do with this error. Sometimes it reappears again later, like 3 days later. Also, what sometimes happens just out of the blue, I keep getting Input/output errors. For example, let's say in the home directory I have a file called foo.txt, I run


and the output shows

Can't read foo.txt: Input/output error

This happened to me last time when I tried to update on many files, and they couldn't be updated. This then pretty much makes the system unusable. Additionally, sometimes when I restart and run startx, the window manager opens and many colors in the interface are different, the terminal doesn't have the backtrack 5 background anymore.

These are some of the problems I have. Anyone else having similar issues, or knows what I can do to fix them. I tried installing to the usb using unetbootin, universal usb installer, and linux live creator, and all of them give the same errors. I also checked my usb drive for errors, and none were found. It is also pretty new, I just got it one month ago specifically to run backtrack on it, so it should be working.

Any help would be appreciated.