Results 1 to 4 of 4

Thread: broadcom bc4318 passing injection test but not working????

  1. #1
    Just burned his ISO
    Join Date
    Jun 2011

    Default broadcom bc4318 passing injection test but not working????

    I am very new to backtrack and the various functions contained in it. I have a little experience with ubuntu but not much. I am wondering if my current wireless setup will work for packet injection since it passes the test perfectly i.e. 30/30 100% good ping rates etc. i have a bc4318 with the b43 chipset the broadcom site claims good for injection as well as a linux machine. I'm thinking i need some of the patches. any help would be greatly appreciated. Love this forum glad to be a member!

  2. #2
    Administrator sickness's Avatar
    Join Date
    Jan 2010
    Behind the screen.

    Default Re: broadcom bc4318 passing injection test but not working????

    You could start by offering us some more details, commands, output, etc.
    Back|track giving machine guns to monkeys since 2007 !

    Do not read the Wiki, most your questions will not be answered there !
    Do not take a look at the: Forum Rules !

  3. #3
    Just burned his ISO
    Join Date
    Sep 2010

    Default Re: broadcom bc4318 passing injection test but not working????

    I used to try and use a broadcom 4312 with bt4r2, I gave up and bought an intel pro card with N instead.

    Broadcrap, as they are known in linux/bsd forums, have pretty shotty compatibility and even if they decide to work sometimes, they drop connections and fail to authenticate with protected networks.

    Long story short, save some time and frustration, replace the wificard with something better (check the compat. list) and buy yourself a good alfa wifi dongle for injection.

  4. #4
    Just burned his ISO
    Join Date
    Jun 2011

    Default Re: broadcom bc4318 passing injection test but not working????

    Thanks guys that is what i'm planning, but I'm failing to understand when I run all the commands from terminal windows I'm good up until the point where airodump is supposed to give me enough data to save in the file I write it to. for example: airmon-ng. then I'm showing just my card and chipset bc4318 and b43 in .... So I run {airmon-ng stop wlan0} then airmon-ng start wlan0 and it brings up mon0 which then is strictly monitor mode or so it says. I then run airmon-ng -c (whatever # channel) -w(whatever I want to name my file) --bssid (whatever it may be) mon0. So, i'm seeing only my network out of many. Then I run airodump in a new terminal window or perhaps that string of commands with the --bssid is in airodump-ng but I know I'm good even when I enter the commands aireplay-ng -1 0 -a (the networks bssid)mon0 i get good authentication with the AP. So, then I run aireplay-ng -5 -b (bssid) mon0 I get a weird mesage saying timedate/good file not found or something close to that then in my aireplay window it starts counting packets but they are not actual data packets for the bssid I specified(or any bssid) and when I look at my airmon terminal no movement on the data. So then I keep trying aireplay-ng -9 etc and everything checks out i.e. injection working! with the 30/30 100% and very strong signal and ping times. So, I guess why are these commands working seemingly perfect but when it comes time I can not get an arp file to inject? sorry for the other post btw. didn't know. thanks I just want to know why I can associate and inject a test but not really perform proper packet injection. Thanks.
    nvrmnd i got it to work im not sure why but my card and chipset do work out of the box for bt5. quite well. I believe the issue lies in some form of the authenticated network association issue .i was able to get a key from most.... but not all. of my friends.
    Last edited by generallee; 07-01-2011 at 06:12 AM. Reason: problem solved

Similar Threads

  1. Broadcom BCM43224 injection is working
    By ferrazrafael in forum Working Hardware
    Replies: 21
    Last Post: 03-28-2013, 06:29 AM
  2. Broadcom Bcm 4311 injection not working
    By bricktop in forum Beginners Forum
    Replies: 3
    Last Post: 02-09-2010, 09:37 PM
  3. Help Injection Test Not Working...
    By elitekevin1 in forum OLD Newbie Area
    Replies: 3
    Last Post: 03-02-2009, 03:25 PM
  4. Broadcom 4311 still not working for injection
    By abitaz in forum OLD BT3beta NON-WORKING HARDWARE
    Replies: 23
    Last Post: 01-14-2009, 06:10 AM
  5. Injection test
    By freebsd_man in forum OLD Newbie Area
    Replies: 5
    Last Post: 11-28-2008, 08:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts