I'm not so new to backtrack, worked around with the 4 version before, but I can still call myself a n00b in linux, finding my way in the dark..
I've just bought this item, Edup MS150N Mini High Power Wireless Network Card, (http://www.focalprice.com/detail_CN093B.html) and it written down on the case that you can install it on linux.
Well, I've tried to install it on BT, but failed to do so. The device came with instructions disc, but I can't figure out from the disc how to install it.
Here's what I've tried so far:
A. Tried to ran the "install.sh" by running
sudo install.sh
. Gave me some error.
B. I ran the commands in the readme file, which is:
Part 1: make 8192C USB Linux driver step by step
(1) step1: uncompress the “rtl8192cu_linux_v2.0.xxxx.2010xxxx.tar.gz” file. (in “driver” directory)
	> tar zxvf rtl8192CU_linux_v2.0.1170.20101112.tar.gz
(2) step2: make 8192C USB driver module
	> make
(3) step3: clean the operation environment
    > ./clean
(4) step4: insert 8192C USB modules 
	> insmod 8192cu.ko
But still - I got an error with the insmod command. I'll attach screenshots of the output soon.

What am I doing wrong?
Thank you.