Results 1 to 3 of 3

Thread: BT5 startx problem

  1. #1
    Just burned his ISO
    Join Date
    Jun 2011

    Question BT5 startx problem

    Inb4 "see 64-bit KDE startx fix thread", I have made a strong effort to view the documentation already in the BT5 forum regarding the startx problem. I, however, have not had any luck so far getting BT5 to work on my setup which is as follows:

    Lenovo Thinkpad X201
    Intel i5
    Intel integrated HD graphics (the 3400 chipset I believe)
    running VMWare Workstation 6 (only way to run BT as the box has no disc drive nor do I have any flash drives large enough to hold images)
    on Windows XP SP3 32bit

    To save space, I am including a forum thread from that is incredibly similar to my setup, problem, and the attempts that I have made to fix things:
    (as in this thread, I am receiving a Signal 4 to kill things off followed by an xorg log that tells me I do not have certain fonts).

    tldr; I have tried the following common methods already:
    -32bit GNOME and KDE .iso files (both have correct MD5)
    -deletion of cache files when using KDE
    -modification of the grub to use older Intel tech (the i915.modeset=1 mod)

    *Please keep in mind that I have not had a successful install of BT, as this problem prevents me from loading the GUI. I have only live disc capabilities.

    I have heard that BT5 doesn't like to play well with Intel HD integrated graphics nor does it like the Thinkpads (but I could be mistaken). I have also heard that BT4 r2 has been working well for most people, however I would like to use that as a last resort. I am coming to you intelligent people for help, if you would be so kind, because I am but a novice linux user and am quickly running out of ideas to try. Any advice you could give me on this topic would be greatly appreciated.

    If you have any questions regarding results and configuration, please let me know. I will try to respond to all requests quickly.

    *Note: I am currently working to prepare a regular linux image to see if the problem is of a broader scale than just BT.

    Moderators: If I have posted in the wrong section of the forum, I apologize. As you can see from above, this post could easily fit in multiple sections.

    Edit: After upgrading the vm software, I was able to get BT running. My guess is that the version that I was using didn't like to play well with my hardware in certain situations. Go figure :P Thank you for the help!
    Last edited by k0ntagious; 06-21-2011 at 04:17 AM. Reason: Problem Solved

  2. #2
    Junior Member Godfrey's Avatar
    Join Date
    Jun 2010

    Default 回复: BT5 startx problem

    Quote Originally Posted by k0ntagious View Post
    running VMWare Workstation 6 (only way to run BT as the box has no disc drive nor do I have any flash drives large enough to hold images)
    on Windows XP SP3 32bit
    You may try the latest VMWare Workstation or use the latest VirtualBox to see if it's a problem with your software.
    And make sure that you have configure your software correctly.

    In my view,the missing message of fonts is just Warnings and it should not cause xserver to fail to start.

  3. #3
    Just burned his ISO
    Join Date
    Jun 2011

    Default Re: BT5 startx problem

    I've heard that too. I'll dig a bit deeper into the log file to see if I can find anything worse than a warning.

    Also, I'm not sure what else I could do to configure the software. I've set the workstation to 6.x, the RAM to about 1gb, hard drive space shouldn't be an issue either. I've set the OS type to 'other' using the 2.6.x kernel and have the rest of the settings on auto-detect.

    I'll do some research on optimal vm software configurations. Thank you for the reply!

Similar Threads

  1. startx Problem
    By FurryTurtle in forum Beginners Forum
    Replies: 2
    Last Post: 07-14-2010, 06:32 PM
  2. problem with startx
    By zerohour in forum Beginners Forum
    Replies: 0
    Last Post: 04-12-2010, 01:34 PM
  3. Startx problem. Sudo startx works
    By chris_heyward in forum Beginners Forum
    Replies: 0
    Last Post: 02-22-2010, 02:41 AM
  4. startx problem
    By WuQ_pl in forum OLD BackTrack 4 General Support
    Replies: 0
    Last Post: 01-27-2010, 04:54 PM
  5. Startx problem
    By digiuk in forum OLD BT3final Support
    Replies: 2
    Last Post: 10-09-2008, 01:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts