Results 1 to 3 of 3

Thread: airmon-ng recognises WLAN in VM image but not installed BT5

  1. #1
    Just burned his ISO
    Join Date
    Sep 2011

    Default airmon-ng recognises WLAN in VM image but not installed BT5

    i a fairly new to linux generally and BackTrack specifically so forgive my ignorance.

    I am trying to learn Wireless Network testing and penetration. I want to test this on my own networks and have never done this before. I have done a lot of research and have some guides on hand to assist me.

    I downloaded BT5, Gnome, x64. I created a Live CD. I booted this CD. Apparently the wireless device, TP-Link WN722NC v1.1 is detected.

    If I type iwconfig i see l0, eth0, wlan0 and wlan1. wlan0 is the onboard device and wlan1 is the WN722NC. Even though wlan0 is showing it does not appear to work. If I disconnect the WN722NC no networks are visible even though the wlan0 is still active.

    However if I enter the command airmon-ng I get the headings Interface, Chipset, Driver but nothing listed.

    I ended up downloading the BT5R1 VM image and botting this machine up in VMware. One this installation I can run the airmon-ng commands and subsequently was able to complete a test compromise of bot WEP and WPA2 encryptions.

    I then tried BT5R1 x64 as a clean install and was again unable to run the commands. I then downloaded BT5R1 x86 and was still unable to have proper access to the network card.

    Why does the VM image work out of the box but the standalone live or installed system does not. Is there changes to the VM image? What is required to get my network card fully operation on the proper installation?


  2. #2
    Just burned his ISO
    Join Date
    Aug 2011

    Default Riferimento: airmon-ng recognises WLAN in VM image but not installed BT5


    the TP-Link WN722NC v1.1 usb adapter should use an Atheros ar9271 chipset. This chipset is supported in the latest ath9k_htc kernel module (

    Did you try with BT5 or BT5R1 they use different kernel and perhaps the BT5 doesn't handle the ath9k_htc module.

    BT5 has kernel 2.6.38 versus BT5R1 that has kernel

    To see what kernel you are running type

    uname -an

    If you are on BT5 either do a clean install from a BT5R1 dvd or try doing

    apt-get dist-upgrade

    which should upgrade the distro over the internet.

  3. #3
    Just burned his ISO
    Join Date
    Sep 2011

    Default Re: airmon-ng recognises WLAN in VM image but not installed BT5

    Thanks for the feedback.

    I double checked what I had tried before.

    The network card works on BT5R1 distributed VM Image. But does not work on BT5R1 Live ISO. On closer inspection I realised that the VM image was 32bit whereas I downloaded the 64bit ISO.

    I retested on a LIVE version of 64bit BT5R1 and the network card was not recognised. I tested on a 32bit BT5 and it worked. So apparently this card works ONLY on the 32bit versions.

    FYI I did "uname -an" on my BT5 x32. Responded with 2.6.38. I attempted to run the command "apt-get dist-upgrade". the response was

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

    So... it did not upgrade the kernal. However it appears the only issue is I have to run 32bit versions and all is ok. Although if anyone can offer advice on getting the Tl-WN722NC working on 64bit than I would love to try it.

    Thanks for your help.


Similar Threads

  1. Replies: 3
    Last Post: 09-24-2010, 03:16 PM
  2. Replies: 3
    Last Post: 07-09-2009, 12:29 PM
  3. BT2 installed, Ubuntu installed, now BT2 wont boot
    By top_score in forum OLD Newbie Area
    Replies: 8
    Last Post: 04-27-2007, 05:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts