Results 1 to 3 of 3

Thread: Black Screen after startx

  1. #1
    Just burned his ISO
    Join Date
    Apr 2009

    Default Black Screen after startx

    I have been doing some reading on the current issue about the black screen after startx. I have attempted the fix with the i915 and as well as deleting the kcache from the .kde directory.

    I have downloaded both versions KDE and GNOME. I have a 64 bit processor and no matter what version I attempt I am getting the same error. However I am not seeing instructions based on the screenshots I have taken.

    The ONLY way I am able to get to the prompt is by selecting the option Backtrack NoDRM. This will take me to the prompt where I can browse files, and as soon as I enter startx I get nothing but a black screen.

    Please take a look at the screenshots I attached. I have pressed TAB on every option so you can see what is able to be edited with each choice. If anyone can point me in the right direction as to what I should replace these lines with it would be awesome! I attempted to type the Xorg -configure command and it goes through but after entering startx its the same ol black screen.
    Immagini allegate Immagini allegate

  2. #2
    Just burned his ISO
    Join Date
    Apr 2009

    Default Re: Black Screen after startx

    OK its been a couple days since posting this and still no go. I have tried doing several other things.

    I attempted the fix for the quiet splash i915.modeset=1 I tried changing the VGa from 791 to 792, I have edited the grub file before running startx and still no go.

    I also ran Xorg - configure = failed
    I tried "find . -type f -iname "*.kcache" -delete and it processed fine but still no go, Black screen when entering startx

    I have attempted the command
    rm /root/.kde/cache-root/icon-cache.kcache
    rm /root/.kde/cache-root/plasma_theme_Volatile.kcache
    rm /root/.kde/cache-bt/icon-cache.kcache
    rm /root/.kde/cache-bt/plasma_theme_Volatile.kcache

    this went through fine but startx failed again

    I then attempted to run the command
    nano /etc/default/grub
    editing Grub_CMDLINE_Linux_Default="quiet splash i915.modeset=1 vga=791"
    sudo update-grup

    Went through and after startx i got the black screen.

    I can hear the DVD spinning and loading everything but no display.

    Any other suggestions?

  3. #3
    Just burned his ISO
    Join Date
    Feb 2010

    Default Re: Black Screen after startx

    this black screen is annoying i got it too one day

Similar Threads

  1. HELP ME! startx gets black screen after intalled NVIDIA driver.
    By Chinese in forum BackTrack 5 Beginners Section
    Replies: 10
    Last Post: 06-03-2012, 03:53 PM
  2. HP DV7 - ATI HD 5650 startx issue (Black screen)
    By mbooma in forum BackTrack 5 Bugs
    Replies: 18
    Last Post: 12-22-2011, 10:32 AM
  3. Black screen and LED flashing at startx
    By PoloB in forum BackTrack 5 Beginners Section
    Replies: 8
    Last Post: 06-27-2011, 04:53 PM
  4. Replies: 5
    Last Post: 01-20-2011, 02:53 AM
  5. Screen goes black after writing startx
    By xaerg in forum OLD LiveCD Support
    Replies: 5
    Last Post: 01-11-2008, 06:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts