Results 1 to 3 of 3

Thread: what the heck! cant get hostap drivers to work

  1. #1
    Just burned his ISO
    Join Date
    May 2007

    Default what the heck! cant get hostap drivers to work


    this is almost driving me mad:
    i use a zcom xi-325hp with the prism2 pri / sta 1.1.1 / 1.7.4 firmware on it.

    regardless of what i do, airmon-ng always says

    Interface Chipset Driver

    eth1 Centrino b/g ipw2200
    wlan0 Prism2 wlan-ng

    ok, first off -- wtf, i thought there was no more wlan-ng on BT2?

    second, i have already tried blacklist and several modprobe and rmmod as well as editing the hostap_cs.c (my zcom card was even in there, with the right id!) and the blacklist file.

    using wikis advice about modprobe -r orinoco(_cs) / hermes && modprobe hostap_cs doesnt work either, and yes i have removed the card before doing this.

    besides this, unloading orinoco appears useless in my case since it seems that the orinoco or hermes driver is never ever loaded, just the wlan-ng and i just cant get it to work with hostap!

    can anyone help me on this one?



    airmon-ng start wlan0
    seems to work at first, but when i want to use airodump it tells me it got troubles with monitor on wlan0

    airmon-ng start wlan0 channel <N>
    will result in invalid operation "Set Frequency" Oo?

  2. #2
    Senior Member shamanvirtuel's Avatar
    Join Date
    Mar 2010
    Somewhere in the "Ex" human right country


    have you check if there is iwpriv commands for the card, if yes use them to set monitor mode and things you need(like me i need to activate rfmontx or my card won't inject).

    just my 2 cents, some cards needs to use iwpriv commands....weird...
    Watch your back, your packetz will belong to me soon... xD

    BackTrack :
    Giving Machine Guns to Monkeys since 2006

  3. #3
    Just burned his ISO
    Join Date
    May 2007


    no, there are no private ioctls either that i could set with iwpriv, i have already checked that.

    the funny thing is, when i use airmon-ng to set it into monitor, it is stated in dmesg that monitor mode was enabled, but when i want to use airodump it says "error setting monitor mode on wlan0"

    i also tried using the old monitor.wlan script but that doesnt exist anymore so i tried the manual way with the wlanctl-ng commands:

    wlanctl-ng wlan0 lnxreq_ifstate ifstate=disable
    wlanctl-ng wlan0 lnxreq_wlansniff channel=8 enable=true prismheader=true
    wlanctl-ng wlan0 lnxreq_ifstate ifstate=enable
    ifconfig wlan0 up

    does the same as airmon-ng.. dmesg says monitor mode enabled but airodump-ng doesnt work. (iwconfig -> wlan0 mode = auto !?)

    BTW i just found that my xi325hp only features 11 channels, should that be a problem?


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts