Ok, so I tried linuxlive key boot maker as well as Unetbootin on two different USB keys...

Whenever I try to run off of the live keys on my laptop, I get errors and/or a black screen. On other computers it works fine.

The error when trying safe mode (in normal, I only get a black screen) I get the error:
Error Atom Bios stuck Executing CBBA 0xCBD6.
I also get a few other error codes but all the same definition of the code.

Also, it starts off with executable_table_locked.

I'm not quite sure what to do at this point... Any ideas?


More details!

The laptop is the Acer 3820TG-7945, with switch-able intel-ATI graphics. I know ubunto can work with switch-able graphics - but I want backtrack 5.

Now, when I enter safe mode...
I get that lovely screen where everything loaded nicely, but I want to startx. So.. I type in startx.
Black screen.

Now lets go to safe mode and press tab, and erase text--. I get to Driver supports precise vblank timestamp query, then stops. sits there for 15minutes. SO, I cut power as CTL-ALT-DEL does nothing.

I get REALLY curious and try entering forensic mode. Not what I want as I'm trying to install it, but hey, just for fun. Black screen.

So, I've tried 32 and 64 bit versions of Gnome. I can go for KDE if you guys think it's a solution, but I've downloaded the Gnome version several times in order to correct this hoping for corrupt ISOs. And I DO want to make it work without disabling switchable graphics. In fact, I haven't tried with it disabled, so I'll give it a shot now.

Black screen... So that didn't solve anything. I'm at a loss here guys. Anyone have any ideas?


Ok, so I tried:

wget http://www2.ati.com/drivers/linux/at...x86.x86_64.run
sh ati-driver-installer-11-5-x86.x86_64.run

Results to follow. Oh, right, just so everyone knows what's going on, I set the discrete graphics instead of switchable in bios... Then did that...

Then just go through the prompts and select recommended (I'm not quite an expert so... if I screw up... then it's probably due to something there...)...

then I ran startx and got a black screen... This is just not working well for me... I can't even get to the stage to install it on my laptop...