Hi all,
first of all congratz for BT5...great!

Hope this match forum rules

Below is a brief summary of what i experienced moving to BT5 till now. At the end specific issue raised trying to change Wifi usb dongle dwl-g122 (E1) modulation via iwconfig command (given that iwpriv is not supported).

Release & env:
Backtrack 5 on VMWAre (Gnome, 32 bit)

D-Link DWL-G122 VerE1 (USB dongle):
correctly detected, driver associated rt2800usb. wlan0 interface created can be moved into Monitor mode, injection works fine, iwlist scan works fine (not tried connect/association).
Airmon-ng works fine also defining specific channel.
airodump-ng works fine on hopping mode or on a defined channel/bssid mode

Now, i noticed that on a wpa-psk wifi network i can successfully deauth a client (myself) via aireplay-ng, but airodump-ng started appropriately is not detecting the handshake, and this is double check parsing collected .cap file with aircrack (0 handshake).
AP is very close (it is mine).
My hipothesis is that I need to set my WiFi usb dongle to the same modulation of the AP (that is 11g, rate 54M), so i tried iwpriv comand but "no support private ioctls".
So used iwconfig command and, finally, experienced the issue:

iwconfig mon0 modulation 11g
>>Error for wireless request
>>"Set Modulation" (8B2F):
>>set failed on device on0;
>>operation not supported

I suppose it is up to the rt2800usb drivers, if so is there a plan to integrate driver version to support one of the above functions in BT5?

Thanks a lot &
My Best Rgards,