Results 1 to 3 of 3

Thread: Problem wit CeWL

Threaded View

  1. #1
    Senior Member
    Join Date
    Jan 2011
    over the under

    Default Problem wit CeWL

    upon trying to run CeWL I got this error

    /pentest/passwords/cewl# ./cewl.rb 
    ./cewl.rb:58:in `require': no such file to load -- spider (LoadError)
    	from ./cewl.rb:58:in `<main>'
    I checked the docs to try to see what dependencies may be needed and installed all of the necessary gems... among those was spider so I specifically did

    gem install spider
    also to make sure it was installed I did a quick

    /pentest/passwords/cewl# gem list -d spider
    *** LOCAL GEMS ***
    spider (0.4.4)
        Author: John Nagro
        Installed at: /var/lib/gems/1.9.2
        A Web spidering library
    It's there but I keep getting the same error

    I opened up cewl.rb but unfortunately I'm not too familiar with ruby so It didn't help much

    also worth mentioning I'm on gnome 64 bit, I do have the ruby opt environment variable set in my .bashrc file and I do have exiftool installed

    I also googled a bit to find a solution and came up with a couple things

    1. the gems spider and arachni don't run well together, but I don't have arachni on my system so that can't be it

    2. the documentation says the reason for that error is the gem is missing, but it clearly is not in my case

    3. It appears a couple people posted this same issue on the backtrack 4 forums... what worked for them was passing the environment variable "export RUBYOPT=rubygems" Unfortunately that doesn't work for me either.

    can anyone else verify this or am I the only one?

    any ideas?

    UPDATE: also when trying to run make in /pentest/telephony/warvox I get a similar error

    /pentest/telephony/warvox# make
    Checking for RubyGems and the Bundler gem...
    -e:1:in `require': no such file to load -- bundler (LoadError)
    	from -e:1:in `<main>'
    make: *** [bundler] Error 1
    again the gem is installed... possibly related???
    Last edited by 2901119; 06-08-2011 at 04:44 AM.

Similar Threads

  1. has anyone been able to get cewl working of backtrack 5
    By mia_tech in forum BackTrack 5 General Topics
    Replies: 0
    Last Post: 05-21-2011, 07:38 AM
  2. Installing CeWL in Backtrack4
    By skidmarq in forum BackTrack Howtos
    Replies: 11
    Last Post: 05-15-2010, 09:52 PM
  3. Booting problem/Flash player problem.
    By Archaic in forum OLD BT3final Support
    Replies: 0
    Last Post: 09-15-2009, 11:37 PM
  4. Replies: 3
    Last Post: 06-17-2008, 08:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts