Quote Originally Posted by sickness View Post
That error should not influence your connectivity, however this is the fix to it:
root@evilbox:~# dpkg-reconfigure wicd
root@evilbox:~# update-rc.d wicd defaults
 Adding system startup for /etc/init.d/wicd ...
   /etc/rc0.d/K20wicd -> ../init.d/wicd
   /etc/rc1.d/K20wicd -> ../init.d/wicd
   /etc/rc6.d/K20wicd -> ../init.d/wicd
   /etc/rc2.d/S20wicd -> ../init.d/wicd
   /etc/rc3.d/S20wicd -> ../init.d/wicd
   /etc/rc4.d/S20wicd -> ../init.d/wicd
   /etc/rc5.d/S20wicd -> ../init.d/wicd
I can confirm that this worked for me as well, but after I ran this command and rebooted during bootup, just before the system would ask me to log in, I get the following, visible error messages:

Intel AES: Intel AES-NI instructions are not detected.
padlock: VIA PadLock not detected.

Funny thing is that I can just type in my username, hit enter, then I'm asked for my password like normal. Not sure if this was caused by fixing the WICD stuff, but it seems highly likely. Pretty weird, but yeah, all is working well now. Thanks Sickness!