Someone once told me that most errors are EEOC errors and therefore I am going to include my background so you know where I am coming from. (EEOC Equipment Exceeds Operator Capability)

I am new to Linux in general and Backtrack and have been a Windows based computer user. So anyone that wants to help me with this problem needs to keep that in mind and any analogies that let me know what and why I am following your solutions will help me greatly in learning and understanding. Thanks

OK, I have access to two wireless cards namely an intel4965 internal laptop card and a Ralink 2870 (3070 compatible) USB. (I have been unable to accurately locate chipset versions for the cards but have taken both apart and can supply you with any number that are on them)

My Laptop is a Gateway P6860FX
CPU Intel Mobile Core 2 Duo T7700 2.4ghz
RAM 4GB (555 Samsung)
64bit capable and I have tried both 32bit & 64bit Backtrack versions for both 4&5

Both have been able to work successfully on various occasions. I have only been working on WEP (because I am a nub and want to start at the beginning). I have followed the same steps each time I use Backtrack (4 or 5) live CD's or via HDD or live USB. I am at a loss as to why it seems to work one minute then doesn't the next. I have also been over at a friends and we have been trying the same thing on his network (because he has a different router and ISP etc...) and I haven't been able to get it to work. I come home and try mine again and it works then on another day I try it and it doesn't with the internal card then does with the external and vice versa. I have also seen it work and not when I have both connected and on or one on one off. Sometimes the packet injection/capture all of a sudden works for no apparent reason. And have had it kick in when I open WICD. I have used different approaches e.g., with or without clients, and even using WPA based attacks etc... just to get the injection/capture working properly, sometimes this works sometimes not. I have watched more than one Gerix tutorial just to see if they are all the same for WEP with clients. So as to negate the possibility of following an inaccurate one.

If you need any information that is more specific in order to help with the troubleshooting then please let me know.

These are the steps I follow each time initially and via the live CD:

1. Load Gerix.
2. Clear old session files (even though it's probably redundant).
3. Select a card then click enable monitor mode. (do I need to change the MAC?)
4. Select mon(#) then re-scan for networks.
5. Then pick the network.
6. Go to WEP tab.
7. Start sniffing & logging.
8. Test injection (this always reports successful).
9. Pick with clients.
10. Associate with AP using fake auth (what does this actually do and is it necessary?)
11. ARP request replay.

Sometimes this is all I seem to have to do for it to work and start injecting and collecting packets. When this doesn't work I have tried creating a packet then injecting it but it gives me the error that it can't find the packet, but it tells me that it did successfully create a packet. ??? I have tried Google searches etc... using various search terms to no avail and have searched through the forums on related and similar situations. I haven't been able to find anything similar or similar enough to be of use. Thanks for any help in advance and please let me know if I have missed something that should have been blindingly obvious. And if I find that in a day or so this thread has been deleted I will know I have missed something really obvious lol.

I can also post any long erm sorry longer specs or information via pastebin if you need me to.

The more I know, the more I find I don't