PROB : I am trying to install Backtrack into my netbook, but for some reason it did not recognize my layout

1. tried "guess map"
2. changed the make of the pen drive(4GB) San disk and Kingston
3. Tried 3 diff pen drives on 4 diff machines(inc one desktop)
4. tried GNOME 32 BIT and 64 BIT.
5.tried different types of keyboard layouts too.
6. Tried a 32 BIT version on a 16 GB pen drive.

When I tried to do with a Ubuntu edition(11.04), I had the same response but
got an error report.

It is as the one below.
__________________________________________________ _

Error activating XKB configuration.
It can happen under various circumstances:
• a bug in libxklavier library
• a bug in X server (xkbcomp, xmodmap utilities)
• X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation

If you report this situation as a bug, please include:
• The result of xprop -root | grep XKB
• The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

__________________________________________________ _______________

Thank you,