Results 1 to 4 of 4

Thread: Advent vega

  1. #1
    Member Oneiroi's Avatar
    Join Date
    Jul 2008

    Default Advent vega

    This is a post in progress, this post will be updated with my install experience and notes for getting BT5 working on the Advent Vega

    errr no idea wtf happened, my whole post got NUKED! 31/05/2011 ~ 21:00 BST, In short nothing I have yet tried has worked so I am looking at shrinking the image <= 4GB to fit on a fat32 /sdcard/ (could not get a single rom to accept none fat32)

    Using your favorite linux distro uncompress and mount the image file

    gunzip bt5.img.gz
    mkdir /mnt/bt5 && mount -o loop bt5.img /mnt/bt5

    You will notice there is a fair amount of free space in the img file,

        4.9G    2.6G    2.0G    57%    /mnt/bt5
    So we have 43% free space causing the image to be > 4GB

    Create a new 4GB img file

    Yeh this is a lazy image atm it crates a 3.7GB IMG I may re-visit this later to get as near 4GB as much as poss.

    dd if=/dev/zero of=./bt5_new.img seek=4000999999 bs=1 count=1
    mount the new image and mkfs

    setup a loop devices on loop1 (loop0 will be used by the bt5.img, you can check if you don't believe me! this is a ext2 filesystem, check using parted if you like)
    I have removed this but if you want you can
    losetup /dev/loop1
    mkfs.ext2 /dev/loop1
    mount /dev/loop1 /mnt/bt5_new

    mke2fs -F  bt5_new.img
    mkdir /mnt/bt5_new && mount -o loop bt5_new.img /mnt/bt5_new
    Use rsync to copy everything with the right user/groups and permissions

    rsync -gioprtuv /mnt/bt5/* /mnt/bt5_new/
    and go grab a beer this will take a while, add --progress if you like (267097 files based on what I am running now 31/05/2011 ~21:28)

    Follow the instructions in the README file, with one difference copy bt5_new.img to /sdcard/BT5/bt5.img


    # sh bootbt
    This Script Needs Root! Type : su
    The 2.2 rom I am running does not come with the "cut" binary

    So replace the top line

    perm=$(id|cut -b 5)


    perm=$(id | busybox cut -b 5)

    For the same effect

    Now working through these ...

    /dev/block/mmcblk0p5 needs to be replaced with /dev/block/mtdblock3
    Constantly getting ioctl LOOP_SET_FD failed: Device or resource busy when trying to mount the image ...

    OK here's where I am at

    busybox losetup /dev/block/loop2 /sdcard/BT5/bt5.img
    losetup: /dev/block/loop2
    yup got bt5.img assigned to block device /dev/block/loop2, working through each step now with these new paths crossing my fingers to get this working before I fall asleep at my damn keyboard

    busybox mount /dev/block/loop2 /data/local/mnt
    mount: mounting /dev/block/loop2 on /data/local/mnt failed: Device or resource busy

    As per Muts' post, any apps running on the sdcard can cause this issue, moving all my apps back to the device has gotted around this issue and presented a new one

    # sh bootbt
    mkdir failed for /data/local/mnt, File exists
    net.ipv4.ip_forward = 1
    chroot: can't execute '/bin/bash': No such file or directory
    Shutting down BackTrack ARM For Xoom

    Update 02/06/2011 ~ 12:48 BST

    Mnaully stepped through each step up to the chroot in the boot bt script

    busybox chroot /data/local/mnt sh
    This got me an "ash" shell inside a new chroot of /data/local/mnt

    /bin # which bash
    /bin # bash
    sh: bash: not found
    /bin # /bin/bash
    sh: /bin/bash: not found
    /bin # ls -la /bin/bash
    -rwxr-xr-x    1 root     root       617344 Apr 19  2010 /bin/bash
    /bin # id
    uid=0(root) gid=0(root)
    /bin # whoami 
    clearly need to spend more time on this and figure out why it can't execute bash even though it is there :S
    Last edited by Oneiroi; 06-02-2011 at 11:50 AM. Reason: almost there?

    OSX 10.6
    Advent Vega (Tegra 250)

    Working on getting BT5 working on the Vega

  2. #2
    Just burned his ISO
    Join Date
    May 2011

    Default Re: Advent vega

    Nice to see your progress, would love to know how it's working.
    I have a Advent Vega my self and I might give this a go

  3. #3
    Developer muts's Avatar
    Join Date
    Jan 2006

    Default Re: Advent vega

    Make sure you dont have any apps stored on the "external" storage... this solved the issue for me.

  4. #4
    Member Oneiroi's Avatar
    Join Date
    Jul 2008

    Default Re: Advent vega

    Quote Originally Posted by muts View Post
    Make sure you dont have any apps stored on the "external" storage... this solved the issue for me.
    thanks muts that's got me a step futher, will update main post.

    OSX 10.6
    Advent Vega (Tegra 250)

    Working on getting BT5 working on the Vega

Similar Threads

  1. BT4 pre live usb win 7 and advent 7555 gx need help
    By david33uk in forum OLD BackTrack 4 (pre) Final
    Replies: 3
    Last Post: 12-04-2009, 05:30 PM
  2. MSI Wind / Advent 4211 compatibility
    By WoolyWhisperer in forum OLD Newbie Area
    Replies: 13
    Last Post: 03-21-2009, 11:39 PM
  3. MSI Wind / Advent 4211
    By WoolyWhisperer in forum OLD Newbie Area
    Replies: 0
    Last Post: 07-13-2008, 10:02 AM
  4. Toshiba Satellite A30 and Advent 7086
    By InSanCen in forum OLD BT3beta WORKING HARDWARE
    Replies: 1
    Last Post: 12-23-2007, 08:01 PM
  5. Pci Error????? Advent 7021 & 70211
    By jonathon123449 in forum OLD LiveCD Support
    Replies: 9
    Last Post: 09-29-2007, 10:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts