Results 1 to 2 of 2

Thread: BT5 --> MSF --> psnuffle not working

Threaded View

  1. #1
    Just burned his ISO
    Join Date
    May 2011

    Default BT5 --> MSF --> psnuffle not working

    Hi all,

    unfortunately I can't get psnuffle to work in BT5 / MSF3.

    This is what happens:

    msf auxiliary(psnuffle) > run
    [*] Auxiliary module execution completed
    [*] Loaded protocol FTP from /opt/framework3/msf3/data/exploits/psnuffle/ftp.rb...
    [*] Loaded protocol IMAP from /opt/framework3/msf3/data/exploits/psnuffle/imap.rb...
    [*] Loaded protocol POP3 from /opt/framework3/msf3/data/exploits/psnuffle/pop3.rb...
    [*] Loaded protocol URL from /opt/framework3/msf3/data/exploits/psnuffle/url.rb...
    [*] Sniffing traffic.....
    [*] The Pcaprub module is not available: no such file to load -- pcaprub

    [-] Auxiliary failed: RuntimeError Pcaprub not available
    [-] Call stack:
    [-] /opt/framework3/msf3/lib/msf/core/exploit/capture.rb:379:in `check_pcaprub_loaded'
    [-] /opt/framework3/msf3/lib/msf/core/exploit/capture.rb:75:in `open_pcap'
    [-] (eval):105:in `run'
    msf auxiliary(psnuffle) >

    Then I tried:

    root@bt:~# cd /opt/framework3/msf3/external/pcaprub/
    root@bt:/opt/framework3/msf3/external/pcaprub# ruby extconf.rb && make
    checking for pcap_open_live() in -lpcap... yes
    checking for pcap_setnonblock() in -lpcap... yes
    creating Makefile
    gcc -I. -I/usr/include/ruby-1.9.2/x86_64-linux -I/usr/include/ruby-1.9.2/ruby/backward -I/usr/include/ruby-1.9.2 -I. -fPIC -fno-strict-aliasing -g -g -O2 -fPIC -DRUBY_19 -o pcaprub.o -c pcaprub.c
    gcc -shared -o pcaprub.o -L. -L/usr/lib -L. -rdynamic -Wl,-export-dynamic -lruby-1.9.2 -lpcap -lpcap -lpthread -lrt -ldl -lcrypt -lm -lc
    root@bt:/opt/framework3/msf3/external/pcaprub# make install
    /usr/bin/install -c -m 0755 /usr/local/lib/site_ruby/1.9.2/x86_64-linux

    ...but that did not help.

    Any ideas?

    Thanks a lot,
    Last edited by rokessler; 05-24-2011 at 06:33 AM.

Similar Threads

  1. AWUS036NH working, then NOT working.
    By LITR00 in forum Beginners Forum
    Replies: 3
    Last Post: 01-03-2011, 04:53 PM
  2. Replies: 1
    Last Post: 07-26-2010, 10:59 PM
  3. psnuffle not present in msfconsole
    By H1tMan in forum OLD BackTrack 4 Software Related Issues
    Replies: 1
    Last Post: 11-28-2009, 06:23 AM
  4. tried psnuffle?
    By prowl3r in forum OLD Pentesting
    Replies: 6
    Last Post: 08-30-2009, 05:54 PM
  5. Belkin F5D7050e - Confirmed working/Not working?
    By Beanz in forum OLD Newbie Area
    Replies: 1
    Last Post: 12-07-2008, 06:53 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts