This was done on a Dell Inspiron 1545 running BT5 32-bit GNOME, installed from ISO. I dual-boot this laptop with Windows 7 Pro.

Hawking support says it's got a Ralink 2500 chipset; more specifically, it's RT2571WF (according to what the picture of the chip says when I looked up the FCC ID at

Short version: will go into monitor mode, but won't do packet injection

Longer version: When I plugged this thing in, 2 errors popped up on my screen. This was before starting Gnome. I saw "phy0 -> rt2500usb_init_eeprom: Error - Invalid RT Chipset Detected" followed by "phy0 -> rt2x00lib_probe_dev: Error - failed to allocate device".

lsusb says "ID 148f:2573 Ralink Technology, Corp. RT2501 USB Wireless Adapter".

The last few lines when I ran dmesg say, in order:
ieee80211 phy1: selected rate control algorithm 'minstrel_ht'.
Registered led device: rt73usb-phy1::radio.
Registered led device: rt73usb-phy1::assoc.
Registered led device: rt73usb-phy1::quality.
usbcore: registered new interface driver rt73usb.
udev: renamed network interface wlan0 to wlan2.

I run iwconfig, and the adapter shows up as wlan2. I ran airmon-ng, and it went into monitor mode. Kismet also seems to run ok with the HWUG1A. However, I did a packet injection test using aireplay -9, and didn't see the message "Injection is working!".