I have a Patriot XT 16 GB thumb drive I have installed BackTrack4-r2 to several times using two methods.

They are in the how to section of this website.

I am running Ubuntu10.04 as my base system on a Dell XPS M1710 with an upgraded hard drive and RAM.

I am using VMware Player with the same Backtrack installed on it. I have the USB stick grabbed by the virtual machine upon power on. The DVD is an ISO stored on my main machine and the virtual machine also grabs that upon boot and mounts it as a DVD. I have tried booting from the virtual DVD and installing.

I also have tried booting the DVD from my main system and running the same install procedure.

The downloaded ISO had been checked with the MD5sum provided. The DVD after being written has also been checked.

I am making sure during the install process, during the fdisk, that I activate the first partition the /boot partition.

All commands and their outputs are the same as the how to that I am following.

The problem is that once the system is rebooted it will not boot from the USB. I have made sure to remove or unmount all CD/DVDs. I have made sure to enable boot from USB options in the BIOS. I have tried it on the virtual, my laptop, one other laptop, and one other desktop. The same result occurs.

I boot, hit the key to select boot device, and choose USB. The system then does nothing but boot into the main system.

Anyone have any ideas?

Thanks for you time,
Earth Bound Misfit