Results 1 to 3 of 3

Thread: wrong radiotap header version

Hybrid View

  1. #1
    Junior Member renn3r's Avatar
    Join Date
    Jan 2007

    Question wrong radiotap header version

    I patched the zd1211b Atheros chipset USB, like this :

    Copy zd1211rw_inject_2.6.20.patch to /usr/src/linux/

    cd /usr/src/linux/

    NOTE: In the following lines, verbose and dry-run have a double dash in front of them.

    patch -Np1 --verbose --dry-run -i zd1211rw_inject_2.6.20.patch

    If it was OK:

    patch -Np1 --verbose -i zd1211rw_inject_2.6.20.patch

    Copy ieee80211_inject.patch to /usr/scr/linux

    patch -Np1 --verbose --dry-run -i ieee80211_inject.patch

    If it was OK:

    patch -Np1 --verbose -i ieee80211_inject.patch

    NOTE: In the following lines, change “2.6.20-1.2944.fc6” to match your particular system.

    cd /usr/src/linux/drivers/net/wireless/zd1211rw
    make -C /lib/modules/2.6.20-BT-PwnSauce-NOSMP/build/ M=`pwd` modules
    cd /usr/src/linux/net/ieee80211
    make -C /lib/modules/2.6.20-BT-PwnSauce-NOSMP/build/ M=`pwd` modules

    Now copy the new modules to the /lib/modules tree to be used.

    cp /usr/src/linux/drivers/net/wireless/zd1211rw/zd1211rw.ko /lib/modules/2.6.20-BT-PwnSauce-NOSMP/kernel/drivers/net/wireless/zd1211rw/zd1211rw.ko
    cp /usr/src/linux/net/ieee80211/*.ko /lib/modules/2.6.20-BT-PwnSauce-NOSMP/kernel/net/ieee80211/
    cp /usr/src/linux/net/ieee80211/softmac/*.ko /lib/modules/2.6.20-BT-PwnSauce-NOSMP/kernel/net/ieee80211/softmac/

    At this point, the simplest method to bring up the new modules live is to reboot your system.
    This is from
    But now when I start aireplay-ng than airodump stop and say wrong radiotap header version. I did just what I described and nothing else.
    Can someone pleas tell me what I did wrong ?

  2. #2
    Junior Member
    Join Date
    Apr 2007



    Just a note....the zd1211 is a zydas chipset not an Atheros chipset. But, what you described for your patching process is the same one I used that worked pretty well for me.

    BUT, the process is detailed...isn't it?

    Some zydas USB units work well and some don't one recommendation is to download and burn the wifimay-0.4 CD and use their very simple but effective zydas patch with their ISO. That way you can check and make sure your zydas does injection....without wondering if the BT2 patching process was done correctly or not.

    Then come back to BT2 after you have confirmed a valid zydas usb and play with the process....turn PC off and reboot, turn the PC off, change the usb plug in position then reboot...and so on. I found some sensitivity to that sort of thing initially.

    Let me know if you need more help.


  3. #3
    Junior Member renn3r's Avatar
    Join Date
    Jan 2007


    I tried with wifimay-0.4 and it didn't work, but I fixed the problem, which was old aircrack on bt2f.

    Thanks for help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts