Hello I'm trying to test my methods on my own wireless router in WEP mode.
I am using the original Backtrack 4 release version posted in the downloads section not R1 or R2 as R2 would not even see the wireless card at all.
I've installed it on a boot-able flash stick with no issues.
I have a laptop with a Intel 2200BG chipset and have never been able to get a definitive answer about whether or not it can do injection with the ipw2200 driver supplied with backtrack 4, the dates of all the other posts are fairly old and refer to changes needed in the driver, and some say no changes needed for injection.
I search all over the web using Google and keep getting sent back to this site and here all past post about similar issues, all tell the poster that he should search better and that they basically are not very smart for not searching Google. One big circle.
here is what I've tried so far and the progress I've made.
start with airmon-ng and found that the wireless card on this laptop is ID'ed as eth1.
I have found this is very common for this card and is of no worry.
So I use, airmon-ng start eth1
and get this response. interface eth1 chipset Intel 2200BG Driver ipw2200(monitor mode enabled)
I leave this window open and start a new terminal.
then I confirm my test signal from my home router with airodump-ng eth1

After confirming that I am receiving many AP's along with my test AP I then
use airodump-ng --bssid xx:xx:xx:xx:xx:xx --channel 6 --ivs -w mytestssid eth1

I start seeing beacons and data counting up, data counting up slowly.
I then leave this open and open another terminal and use aireplay-ng -5 -b xx:xx:xx:xx:xx:xx eth1.

I get this response
No answer, repeating
trying a LLC NULL packet
sending fragmented packet
still nothing, trying another packet
I hit 'y' for yes
and it just goes on.

Oh the .ivs file does continue to get larger but I'm afraid it would take days to get enough packets from a system that has little or no activity.

So I then tried aireplay-ng -9 eth1
It finds all WEP encrypted AP's in my area but no answers.
To me from what very little I know this is telling me I am not able to inject packets?
Any help or constructive suggestions would be greatly appreciated. Thank you for your time to read this poorly written question.