I was using bt4 on virtualbox w/ guestadditions installed w/ no problems.

Then I just tried upgrading to kernel using the instructions here

Then guestadditions stopped working. I tried to reinstall it similar to these instructions: http://www.backtrack-linux.org/wiki/...ng_BT4_In_VBox

But now it won't install and gives me the following error msg:
Failed to install using DKMS, attempting to install without
make KBUILD_VERBOSE=1 -C /lib/modules/ SUBDIRS=/tmp/vbox.0 SRCROOT=/tmp/vbox.0 modules
/usr/src/linux-headers- /usr/src/linux-headers- No such file or directory
make[1]: *** No rule to make target `/usr/src/linux-headers-'.  Stop.
make: *** [vboxadd_test] Error 2
The problem seems to be w/ the missing file /usr/src/linux-headers- from the linux-headers- package. But this file just so happens to be referenced by another file inside that same package (/usr/src/linux-headers- line 39), which makes it a bug.

missing file: /usr/src/linux-headers-
in package: linux-headers-

referenced by file: /usr/src/linux-headers-
in package: linux-headers-