Results 1 to 5 of 5

Thread: Alfa network adapter does not connect to AP

  1. #1
    Just burned his ISO
    Join Date
    Apr 2011

    Default Alfa network adapter does not connect to AP

    I have Backtrack4 installed as a dual boot with Vista in my Acer Aspire 5315 laptop. I can connect to my access point with my inbuilt wireless Atheros AR5007EG wireless adapter by starting services/network and WICD. The problem I have is connecting my Alfa network RTL8187 wireless through WICD or wireless assistant. My Alfa network adapter works fine as I have used it with Aircrack-ng in BT4.

  2. #2
    Administrator sickness's Avatar
    Join Date
    Jan 2010
    Behind the screen.

    Default Re: Alfa network adapter does not connect to AP

    And what exactly is the problem? Could you give us more details?
    Back|track giving machine guns to monkeys since 2007 !

    Do not read the Wiki, most your questions will not be answered there !
    Do not take a look at the: Forum Rules !

  3. #3
    Just burned his ISO
    Join Date
    Apr 2011

    Default Re: Alfa network adapter does not connect to AP

    My inbuilt Atheros wireless adapter can connect to my AP but when i try to connect with my Alfa network adapter I keep getting connection failed. I has doubled-checked the settings and my WPA key yet I still can not connect with my Alfa network adapter. As I said on my first post, I can use the Alfa network adapter with Aircrack-ng and Kismet so why can I not connect to my AP with it?

  4. #4
    Junior Member
    Join Date
    Feb 2011
    NE USA

    Default Re: Alfa network adapter does not connect to AP

    Haha, Im in just about the same boat. I use the Alfa AWUS 036H for the obvious extended capabilities, but I can't connect to wicd with it, I had to use only my integrated Intel 4965 to do that. My problem is that somewhere along the line, my integrated Intel card was moved into wlan1 position and the Alfa dongle shows up as wlan0. wlan0 is set to auto boot into wicd and the network thereafter, but because I was using the integrated for internet and the dongle for pentesting, i now find myself running with crossed legs

    i think Daveit wants to use his Realtek as his primary NIC and his integrated as his secondary. Explaining how to alter either i believe will remedy both our problems.sues worked itself out
    My wicd issue worked itself out, but I'd still like to know how to reassign wlan0 or 1 to whatever NIC I choose in the event this goes south again. Thanks in advance
    Last edited by freemyggle; 04-21-2011 at 04:09 AM.

  5. #5
    Just burned his ISO
    Join Date
    Mar 2011

    Cool Re: Alfa network adapter does not connect to AP

    Open a shell, type

    /etc/init.d/wicd start

    That will start wicd, but you can then go to the graphical interface, go to menu:internet:wicd for wicd gui.. If no networks are shown then go to the preferences: you'll see a box with

    wireless interface wlan0
    wired interface eth0

    Change the wlan0 to wlan1
    Then refresh networks, you'll then see networks to choose from.
    Ok now if the card connects but firefox says "cant find server"
    then have you enabled UFW? UFW in backtrack interferes with the iptables that are already set up in bt. So if you have UFW enabled then disable it.

    ufw disable

    Then run this command

    iptables -F

    This will flush the iptables,
    then try to connect through firefox.
    Keep UFW off.
    Also you can run these commands to connect.

    iwconfig wlan1 essid 'yourAPname'
    iwconfig #you should see your AP name then type
    dhclient wlan1

    It should connect then youll see at the end
    bound to -- renewal in xx seconds #This is your inet addr on wlan1. type ifconfig #To check, then start Firefox
    Also one more thing, inside Firefox go to File,click,then look at the bottom of the menu and make sure the "work offline" is unchecked.

Similar Threads

  1. which alfa usb adapter should i buy
    By turkystick in forum Beginners Forum
    Replies: 10
    Last Post: 06-14-2010, 06:15 PM
  2. Replies: 1
    Last Post: 04-17-2010, 06:36 AM
  3. WG111v2 usb adapter, fails to
    By humpy in forum OLD Newbie Area
    Replies: 2
    Last Post: 07-08-2009, 07:30 AM
  4. Replies: 2
    Last Post: 04-21-2009, 11:30 AM
  5. Replies: 18
    Last Post: 04-22-2008, 07:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts