Results 1 to 3 of 3

Thread: Strange problems with HDD install onto a Toshiba NB205

  1. #1
    Just burned his ISO
    Join Date
    Mar 2008

    Default Strange problems with HDD install onto a Toshiba NB205

    First I have searched these forums and google for the last three days to no avail. I am also decently familiar with Linux systems and have been using prior backtrack releases with little problem.

    Basically here is what is going on, I boot the Toshiba NB205 from a 4gb USB stick loaded with Backtrack 4 Final ISO via unetbooin. The OS boots rather quickly and also X starts up rather quickly as well with startx.

    The problems start when performing the install. While the is running after choosing all the options, it will seem to freeze unless I provide some sort of input such as moving/clicking the mouse cursor or hitting caps-lock. I seemingly have to do this quite often through the install to keep it "motivated" it seems. You can tell when it has reached one of these "frozen" points by watching for the HDD light to stop showing activity.

    After the system is installed, It will boot with a kinit error yelling about some hibernation kernel. I tried to fix that using methods found on one other site with unfortunately no resolve. Then, the system will take at least 90 seconds or more to boot. Once started I try to do a startx and that takes quite a bit to load as well. When trying to do apt-get update and then apt-get upgrade, I get the same "freezing" issue during the install of the packages and I periodically have to hit caps-lock to keep the system "motivated" it seem.

    I would give more details but it's not like there are any real specific error messages. Any help or suggestions would be greatly appreciated.

    *Update* I found that if I hit the power button at the very long pause then it for some reason "kick starts" the machine into gear.
    Last edited by Denkishi; 10-19-2010 at 10:26 PM.

  2. #2
    Member macphail's Avatar
    Join Date
    Jun 2010
    East Coast, USA

    Default Re: Strange problems with HDD install onto a Toshiba NB205

    greets, Denkishi~

    interesting problem.
    keeping in mind that bt4 is based on hardy, i did some sniffing around on this and have a couple of suggestions:

    firstly, from here:

    i found an interesting passage:

    Unfortunately, ubuntu has mangled disk idling into event handling and power state switching in the past. And this did not deliver idle disks but break disk idling (laptop-mode) features by leaving undefined (factory default) apm settings in place.
    To correct disk-idling in Ubuntu Hardy you need to adjust the following:

    • Enable CONTROL_HD_POWERMGMT=1 in /etc/laptop-mode/laptop-mode.conf
      • (Bug 244832 missing hdparm -B setting during boot (fixed in intrepid 250935))

    • ENABLE_LAPTOP_MODE=true in /etc/default/acpi-support (another package's conffile), even if you do not ENABLE_LAPTOP_MODE_ON_BATTERY or _ON_AC in laptop-mode.conf. So that laptop-mode-tools can control the harddisk power management settings.
      • (244838 laptop-mode needs to be activated in two places)

    • Delete or #comment the four $HDPARM blocks (for...done) in /etc/acpi/ and change the two $LAPTOP_MODE start/stop lines to "$LAPTOP_MODE auto"
      • (244836 /etc/acpi/ overrides user settings (fixed in intrepid 250938))
        (244831 /etc/acpi/ overrides user scripts (fixed in intrepid 250938))
        (244844 Adapt laptop-mode-tools invocation to ubuntu's acpi-support / pm-utils packages (fixed in intrepid 250935))

    • Create an empty "laptop-tools" file (touch /etc/pm/power.d/laptop-tools) to override /usr/lib/pm-utils/power.d/laptop-tools.
      • (239419 pm-utils has laptop-tools script which conflicts with laptop-mode-tools (not so in intrepid))

    With the above changes hardy (ubuntu 8.04) will set the hdparm -B value to 254 when booting and thus override inadequately aggressive hardware defaults that cause load cycling. Not all harddisks will stop head parking with value 255 and some may even overheat. (hdparm -B255 turns off the disk's apm feature, but this only turns off the spin down timer in many disks and doesn't increase the head parking timer at all, which is the issue here.)
    Other issues/adjustuments are related to have the hdparm -B value also reset after a suspend/resume cycle (fixed in intrepid 250935).
    244833 missing hdparm -B setting during resume
    244839 /etc/acpi/start.d and resume.d scripts are not run.
    244844 Adapt laptop-mode-tools invocation to ubuntu's acpi-support / pm-tools packages also:
    238555 pm-utils doesn't reload hdparm.conf after a suspend
    there was also this:
    but it lists hardware affected and your specific Toshiba isn't in the list.

    however, an interesting troubleshooting step to follow may be to research your hd access with smartmontools.

    take a look here for a bit of background from a similar issue:
    My experiments with Linux: Harddrive killer bug, workaround for Ubuntu Hardy Heron

    you seem to be having the reverse of the issue, but it may very well be related or offer you clues as to what is causing this.

    i'm not too sure that this is caused by anything that the BT devs have introduced to the OS from stock, so you may have better luck grep'ing ubuntu/debian forums on this one.

    at any rate, if you get this solved please post your solution in case others run into this.

    good luck with that...

  3. #3
    Just burned his ISO
    Join Date
    Apr 2011

    Default Re: Strange problems with HDD install onto a Toshiba NB205

    Hi there
    I also have a toshiba notebook. The hdd is in campatible sata mode (bios setting) cause I've got the sata hdd connected to the ide slot (which is kind of weird thing that the manufacturer did)...
    The MBR is overwritten by the BT4 Grub, it works fine, loads WinXp and BT4 as well.
    My problem is kind of similar - sometimes it happens that just after I log in the BT4, after I saw the starting X module (screen changes - as for the resolution changes), then it goes blank and the only thing is the blinking Caps-Lock diode. System isn't hanging (or at least the bios) cause I still can turn on/off NumLock, pressing several keys at once make the bios *BEEP* but the BT4 doesn't start at all, it's just somehow paused with the Caps-Lock blinking... Can't see anything cause of the screen is blank (black).
    It's happening just sometimes, mostly when I reboot BT4. Starting from "scratch" is all fine, I mean starting from completely turned off pc.

    I'm noob with BT4 (used to have BT3 on usb), used to play with several linux distros but know nothing about command line configs and editing system protected files....

    It doesn't bother me so much, cause I can always turn the pc off and start it again, but solving it may help other toshiba users. And a hint of a possible bug in BT4

Similar Threads

  1. BT4 problems on Toshiba Satellite L500
    By shadow6991 in forum Beginners Forum
    Replies: 7
    Last Post: 11-16-2010, 01:10 PM
  2. Slow Boot on Toshiba NB205-NL325 w/BT4 r1
    By siviog1 in forum Beginners Forum
    Replies: 1
    Last Post: 08-09-2010, 07:41 PM
  3. toshiba netbook nb205 wireless adapter isnt working
    By dixienormous206 in forum OLD Newbie Area
    Replies: 1
    Last Post: 09-14-2009, 05:20 AM
  4. Some strange problems with injection
    By Fenriswolf in forum OLD Newbie Area
    Replies: 4
    Last Post: 01-10-2009, 02:59 AM
  5. Toshiba Tecra A7 problems
    By map777 in forum OLD BackTrack v2.0 Final
    Replies: 0
    Last Post: 05-03-2007, 03:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts