I want to use Backtrack r2 on my computer. I boot it from the Live DVD. I get stuck at a flashing white dot - I wait and then a lot of lines pop up(can not see all of them - some flashes by very quickly). There is a flashing white dot after the message, usb has also shut down. This is the message(all hand-written, may be wrong somewhere):

[<c0718c41>] ? schedule+0x291/0x640
[<c012e8c1>] ? enqueue_task+0x41/0x60
[<c012ea0e>] ? try_to_wake_up+0x8e/0x260
[<c071948d>] ? schedule_timeout+0x16/0x1d0
[<c0123222>] bad_area_nosemaphore+0x12/0x20
[<c012364c>] do_page_fault+0x28c/0x380
[<c06ebde8>] ? klist_next+0x38/0xc0
[<c0399e43>] ? bus_find_devide+0x63/0x90
[<c01233c0>] ? do_page_fault+0x0/0x380
[<c071b3de>] error_code+0x66/0x6c
[<c01233c0>] ? do_page_fault+0x0/0x380
[<c06f602a>] ? via_init_one+0xba/0x280
[<c03089a0>] ? kobject_put+0x20/0x50
[<c06ebf04>] ? klist_iter_exit+0x14/0x20
[<c03d5c00>] ? init_chipset_via82cxxx+0x0/0x250
[<c0976699>] ide_scan_pcibus+0x59/0xf0
[<c0976546>] ? piix_ide_init+0x66/0xad
[<c097627b>] ? ide_init+0x6b/0x72
[<c0976640>] ? ide_scan_pcibus+0x0/0xf0
[<c0101123>] do_one_initcall+0x23/0x170
[<c016b587>] ? init_irq_proc+0x67/0x80
[<c094b3d2>] kernel_init+0c151/0x1f0
[<c094b281>] ? kernel_init+0x0/0x1f0
[<c0103136>] kernel_thread_helper+0x6/0x10
My computer setup:
Asrock Fatal1ty P67 Professional
Intel i7 2600K
Corsair Dominator GT 2000Mhz 2GB (x2)
Corsair AX1200
OCZ Vertex 2 60GB (x3) SSD
1TB Samsung Spinpoint F3 HD103SJ
Gainward Golden Sample "Goes Like Hell" GTX 570 (x2)
Creative Fatal1ty X-Fi Titanium Pro
Samsung SH-S223C 22X DL Svart
AOpen IDE DVD Burner

I have allready tried resetting bios without any success. I have tried the DVD on other computers where they work flawlessly.

(I have probably forgot something but just ask and I will answer as good as possible.)

Please, help me into getting it to work!