Of course, before posting here I have read all similar threads in:
but i found no solution

I am using persistent USB.

I have found a lot of solutions suggested.Though none does for me.

First of all: I have downloaded BT4R2 1 week ago. I had problems with my chipset/driver issue( i have RT2870/RT3070 chipset and i use a rt2800usb driver, a popular member of aircrack-ng suggested me, and it worked). I was able to monitor and inject excellent(i think as i haven't tries with another driver to compare). I am sure that i was as i managed to crack my AP(using WPA)

After cracking several times my AP(several because i was trying different options etc.) i rebooted my PC logging in ubuntu to explore more stuff. Then i rebooted back to Backtrack to "play" again with aircrack. after using airodump-ng -c mychannel ...etc.... i used aireplay to provoke a handshake (i had another PC near me connected to my AP) but nothing happend even if i tried several times.
Not only that but even if i manually disconnect and then connect with my other PC, no handshake...

I reboot...nothing

Then i used wicd to "google" in order to find a solution but i realised that i could not connect.

Wicd then pop an error message saying: couldn't connect, Bad Password(or smthing like this)
Of course the password i use is correct(its MY AP) and i have the option passfrase enabled(as i use WPA)

*I have not enabled macfiltering*
*I can connect using the same USB adaptor using ubuntu or windows7*
*i have tried to connect manualy*
*I have read "How to start networking in Backtrack*
*wicd curses not working too!*

Here is a screenshot:

I hope that my post is clear enough

P.S:sorry about my englsh

waiting for a response