Backtrack fails to boot up from my external hard drive. it was working fine earlier. but i took it with me to school and me and a buddy fiddled around with the console. then when i tried to boot it up, it just gave me a
USB: device not accepting address error 71 and 110s.

I have also unplugged it and booted backtrack from a cd and that worked with no usb errors. i've searched the net for the past 2 hours trying to find a solution yet none retain to mine.

the last thing i did before i disconnected it from my Desktop was delete grub installed in the MBR of my internal hard drive and installed grub into my external hard drive. then i took it to school. then me and my buddy booted it up on his laptop and that worked! don't know why it doesnt here.

so i've given up.

if there's any simple solution that can really help me, that would be great. solutions such as helping me boot up backtrack with grub again.

but if not, is there a way to reformat the external hard drive back to NTFS so i can install maybe ubuntu this time or some other time.

so if you do help, Thanks!