Results 1 to 1 of 1

Thread: Sony VPCYB16KG Driver problems, Atheros AR9285 - Synaptics Touchpad - Radeon HD 6310

Threaded View

  1. #1
    Just burned his ISO
    Join Date
    Feb 2010

    Default Sony VPCYB16KG Driver problems, Atheros AR9285 - Synaptics Touchpad - Radeon HD 6310

    Okay so I got a new Laptop recently, A Sony VPCYB16KG. and I have several driver problems. The most annoying concerning the wireless driver, It has a Atheros AR9285 wireless card, I have the ath9k driver working for aircrack, it goes into monitor mode and injection works fine, but It wont connect to any wireless networks. I have tried installing linux-backport-modules to no avail. I have started up wicd to check if it can scan for any networks, I get the two I would expect, but when I try to connect to my home network, I get Cannot Connect : Bad Password, I have double checked that I have the correct password, Its a WPA2 network. Having a look through dmesg after it fails I have the lines:

    wlan0: authenticate with Mac_Address (try 1)
    wlan0: authenticated
    wlan0: associate with Mac_Address (try 1)
    wlan0: RX AssocResp from Mac_Address (capab=0x431 status=0 aid=1
    waln0: deauthenticated from Mac_Address by local choice (reason=3)

    and this repeats a few times, I assume as it tried to connect. Other people have the problem where wlan0 doesnt show up as an interface in iwconfig, mine does, as you could assume from being able to put it into monitor mode.

    Secondly is the touchpad. Its a synaptic touchpad I assume as In windows it has the synaptics drivers installed. Google reccommends apt-get ing the synaptics drivers, but we cant get them because we dont have the ubuntu repositories. Suggestions on this would be appreciated. I have been using a usb mouse which works fine, its just a pain not being able to use the touchpad.

    And the third is the Video card drivers for the AMD radeon HD 6310 graphics card, the impression i have is that this card isnt natively supported, and we have to install some special driver. The screen works and all, Just the resolution is massive.

    Any help is greatly appreciated!

    EDIT: Forgot to mention that I'm running backtrack 4 r2 dual booting with windows 7, not that that dual booting should make a difference.
    Last edited by eyeofspace; 03-30-2011 at 11:25 PM. Reason: Additional Information

Similar Threads

  1. Atheros ar9285 Driver
    By mixit in forum Beginners Forum
    Replies: 28
    Last Post: 12-18-2010, 03:45 AM
  2. ATHEROS AR9285 problema driver BT3
    By calo88 in forum Supporto Hardware
    Replies: 1
    Last Post: 10-28-2010, 09:03 PM
  3. WPA Handshake Capture Problem - Sony Vaio with AR9285
    By sl4ck3r in forum OLD BackTrack 4 General Support
    Replies: 3
    Last Post: 12-08-2009, 10:09 PM
  4. Synaptics Touchpad Problem!!! Help! = (
    By slakero in forum OLD BackTrack v2.0 Final
    Replies: 1
    Last Post: 12-18-2007, 01:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts