Kernel: Linux bt #1 SMP Sun Nov 14 06:32:36 EST 2010 i686 GNU/Linux
Wireless Card: Intel Centrino Advanced-N 6230 (2x2 b/g/n+ Bluetooth Combo Card)

I've had to resort to posting for help with this one, i've got a fairly new SandyBridge Dell XPS with the wireless card in the subject and i've spent the best part of a day trying to get backtrack to work how I want it to.

I know enough to get around Linux but am mostly at home in debian and have rarely had to mess with drivers so this is pretty new to me.

I've had a long battle with X but have managed to get it running on the intel gpu at low res and now i'm moving onto the wifi.

When I do a /etc/init.d/networking start eth0 comes up fine and gets a DHCP address if i've got it connected but every other interface (and there are a few - bluetooth, wwan mobile, wlan) fail to start.

If I run "ifconfig wlan0 up" I get:

ifconfig wlan0 up
wlan0: ERROR while getting interface flags: No such device
My first stop was where I downloaded iwlwifi-6000g2b-ucode- and dumped the ucode file in /lib/firmware and rebooted with no success.

What has confused me a little is that the main page of the site says

"Note: The iwlwifi driver has been merged into mainline kernel since 2.6.24. If you are using kernels after this release, please use the intree (drivers/net/wireless/iwlwifi) driver directly."

This suggests to me that BT using should "just work" as the card is listed on the main page as a supported one...

The closest i've managed to get to any kind of working was by trying to use the compat-wireless iwlagn driver but I followed a guide to install it all along the lines of:



cd /compat-wireless-2.6

./scripts/driver-select iwglan


make install

make wlunload
(not sure if it was wlunload or something slightly different but either way I rebooted after anyway)

With this done I gained a new interface in ifconfig - wwan0 which I think is the mobile broadband card not wlan.

After much messing in that state I found that rfkill was showing all interfaces were both soft and hard blocked and it wouldnt unblock them - the fn+wifi switch simple unblocked the bluetooth for some reason

I've reverted from this setup to a new one with just the firmware installed and no compat-wireless and rfkill now shows:

0: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
1: dell-wifi: Wireless LAN
        Soft blocked: no
        Hard blocked: no
2: dell-bluetooth: Bluetooth
        Soft blocked: no
        Hard blocked: no
3: dell-wwan: Wireless WAN
        Soft blocked: no
        Hard blocked: no
I'm just weary of trying to install compat-wireless and iwlagn again incase it all goes wrong again.

Does anyone have any pointers? i've done no end of googling but it doesnt seem many have tried to use this card with BT or at least not many people are talking about it!

Sadly this is just part one of getting the wireless working as I'm not sure if this card supports injection or whether it can be added with a patch but i'd just like it to work first!