I'm new to backtrack and I'm trying to pivot Nessus through metasploit.

I have my attacker computer on the same subnet as victim 1 (
victim 2 in connect to victim 1 but is on a different subnet( and not reachable from the attacker directly.

Once I have meterpreter access on victim 1 I use 'run autoroute -s' . Then I can reach and exploit victim 2 from the attacker.

This works fine and the pivot is setup.

What I'm trying to do now is run a nessus scan on Victim 2.

I've tried following the following instructions, but I've had no luck



msf> use auxiliary/server/socks4a
msf auxiliary(socks4a) > run[*] Auxiliary module execution completed[*] Starting the socks4a proxy server

I add the following to the end of my proxchains config file
socks4 1080

the following command works 'proxychains nc 445'. So I can netcat to the distant, victim 2 subnet.

then I startup the nessus bridge in msfconsole.

sf auxiliary(socks4a) > load nessus[*] Nessus Bridge for Metasploit 1.1
[+] Type nessus_help for a command listing
[+] Exploit Index - (/root/.msf3/nessus_index) - is valid.[*] Successfully loaded plugin: nessus

NOTE: It says its for Metasploit 1.1 I don't know why this is, I've tried updating, shouldn't it be 4.2???

I can scan victim 1's subnet( which isn't suprising ) but when I try to scan victim 2's subnet the nessus scan finishes within 10 seconds and doesn't find the host.

I don't get any errors or anything.

Any help with this is very much appreciated.