Results 1 to 2 of 2

Thread: Chntpw isn't working.

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Feb 2011

    Default Chntpw isn't working.


    When i start the chntpw tool from the menu i get a message in terminal with all the info about the tool, but if i type "chntpw -whatever" it gives me the message:
    The program 'chntpw' is currently not installed. You can install it by typing:
    apt-get install chntpw
    bash: chntpw: command not found
    Then i try to do "apt-get install chntpw" and it says:

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    chntpw is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    And of course it still doesn't work as it didn't install anything.

    I tried running "apt-get update" and then installing again but with the same result.

    Help much appreciated (:

  2. #2
    Administrator sickness's Avatar
    Join Date
    Jan 2010
    Behind the screen.

    Default Re: Chntpw isn't working.

    root@evilbox:/pentest/passwords/chntpw# ./chntpw
    chntpw version 0.99.6 100627 (vacation), (c) Petter N Hagen
    chntpw: change password of a user in a NT/2k/XP/2k3/Vista/Win7 SAM file,
    or invoke registry editor. Should handle both 32 and 64 bit windows
    chntpw [OPTIONS] <samfile> [systemfile] [securityfile] [otherreghive] [...]
     -h          This message
     -u <user>   Username to change, Administrator is default
     -l          list all users in SAM file
     -i          Interactive. List users (as -l) then ask for username to change
     -e          Registry editor. Now with full write support!
     -d          Enter buffer debugger instead (hex editor),
     -t          Trace. Show hexdump of structs/segments. (deprecated debug function)
     -v          Be a little more verbose (for debuging)
     -L          Write names of changed files to /tmp/changed
     -N          No allocation mode. Only (old style) same length overwrites possible
    See readme file on how to get to the registry files, and what they are.
    Source/binary freely distributable under GPL v2 license. See README for details.
    NOTE: This program is somewhat hackish! You are on your own!
    Back|track giving machine guns to monkeys since 2007 !

    Do not read the Wiki, most your questions will not be answered there !
    Do not take a look at the: Forum Rules !

Similar Threads

  1. chntpw not working for me
    By lordplagueis in forum Beginners Forum
    Replies: 5
    Last Post: 12-08-2010, 11:03 PM
  2. fix chntpw in kde menu
    By joker5bb in forum Beginners Forum
    Replies: 1
    Last Post: 11-25-2010, 09:45 PM
  3. fix chntpw in kde menu
    By joker5bb in forum BackTrack Bugs
    Replies: 1
    Last Post: 11-25-2010, 09:45 PM
  4. Chntpw
    By trevelyn in forum OLD Tutorials and Guides
    Replies: 4
    Last Post: 05-17-2008, 12:33 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts