Hi all. I've some trouble while trying to boot BT4r2. With an 8GB pendrive it runs perfectly on my two computers, but, with a 32GB unit, it stops booting when the message "[sdc] Assuming drive cache: write through" is reached. See attached image.
Please note these details:
-Both BT4r1 and BT4r2 run perfectly with an 8GB pendrive on the same hardware, the trouble, most likely, is caused somewhere at the 32GB pendrive. It's a "Kingston data traveller", by the way.
-BT3, runs perfectly from this 32GB pendrive.
-I've tried installing BT4 with both unetbootin and linux live loader from a WinXP machine. 8GB unit always worked, 32GB unit never did. I've tried no less than 4 modern computers, it's not a computer issue, that's for sure. Same results were obtained when using an Vmware virtual machine.
-The 8GB drive has a single WIN32FAT partition (0x0B), the 32GB unit has a single WIN32FAT(LBA) partition (0x0C). I've tried changing the system partition ID (with fdisk) from 0x0C to 0x0B, but no luck, everything stayed the same. BT3 worked anyway, so it's probably not the partition ID either.

In the meantime, I've fallen back to BT3, but I do want to use BT4 on this drive. Any help would be greatly appreciated.