I thought this might be helpful to anyone trying to decide on either adapter for BT4 r2 on a Vitual machine.

I am by no means any where close to an expert so take that into consideration before blasting me

I have a Dell 1545 laptop with a Broadcom PCI wireles adapter and I am using BT4 r2 . The Broadcom works with packet injecting (USB BT4r2) but its random and sometimes gives me grief. So, I recently bought a Hawking HUN3 wireless adapter and it worked right out of the box in the virtual environment and can inject packets with no problems. It actually works really well, however, its range is a little weak so I decided to get a ALFA AWUSO36H adapter with a 9dBi antenna. The range is amazing and it also worked right out of the box. One note on the ALFA is that it was randomly giving me a [phy1]SIOCSIFFLAGS: Unknown error 132. Even after taking the interface down and doing the standard things to reset it I would get the error. I also would get the same random results in the USB environment. I noticed that every time I would plug the HUN3 in the ALFA would then work as well. I still don't understand why this happens but it does fixe the error when I use both adapters every time. After hours of trying to figure this out I think its actually a USB connection thing. When I try different ports it will eventually work. So if you run into that problem and dont have two USB adapters save some time and try different ports. Other than that its nice having a few interface options. and I would recommend them both. The ALFA has the edge in two areas...price and range but if you need something fast you can find the Hawking at a local store and skip waiting for the mail every day like 8 year old

Hope this wasnt to long winded and helpful to anyone trying to decide or having a SIOCSIFFLAGS: Unknown error 132.