Results 1 to 3 of 3

Thread: Error 132 in VMWare but not in Oracle VirtualBox...?

  1. #1
    Just burned his ISO
    Join Date
    Jan 2011

    Default Error 132 in VMWare but not in Oracle VirtualBox...?

    Over the last few months I have been trying to get more familiar with BackTrack4. I have noticed when using the 802.11 wireless vulnerability assessment tools, such as airmon-ng/aircrack-ng within a virtual environment using VMWare Workstation, BackTrack continues to produce errors when trying to start the WLAN0/MON0 interfaces one particular USB ports.

    The error it produces is - "ioctl(SI0CSIFFLAGS) failed: unknown error 132"

    As soon as I disconnect the external wireless antenna I am using (Alfa AWUS036H 1000mW) from VMWare and the PC/laptop itself and re-connect to a different USB port, it works fine within VMWare for a period of time and then the error re-occurs. Often moving from USb port to USB port or affecting two at the same time.

    This occurs when using both the virtual machine direct from the BackTrack website as well as the live CD ISO within VMWare.

    However, when I use BackTrack 4 (VM & ISO) with the same applications and hardware on the very same PC within a virtual environment using Oracle VirtualBox and the same USB ports as before, everything works fine, even immediately after the error appeared in VMWare prior to a system re-boot or the adaptor being disconnected and without any system changes being made.

    This has occurred on numerous machines I have tried.

    Has anyone else experienced this and if so, found a solution, other than just using VirtualBox? I would like to get this resolved to work within VMWare in order to use such functionality as recording items for discussing and review at a later date and the option to view at a desired full widescreen resolution etc.

    I have checked the FAQ's and the Wiki, however, nothing jumps out at me about this subject.

    System configuration -

    Physical PC -
    • Windows 7 Professional
    • i5 CPU
    • 4GB DDR Memory
    VMWare Workstation - 7.1.1 build 282343
    Oracle VirtualBox - 4.0.0 r69151
    BackTrack 4 R2 (VM & ISO)


  2. #2
    Member fightclub's Avatar
    Join Date
    Jul 2010
    On some rock in the Milky Way

    Default Re: Error 132 in VMWare but not in Oracle VirtualBox...?

    This is do because the rfkill tends to shutdown the radio off of the chipset rtl8187 which I believe the alpha has. This has been discussed so many times and was put in the wiki of backtrack. Rtl8187 vs r8187 - BackTrack Linux here. You have to kick the wifi off of the hard block of the rfkill. You could try the "rfkill list" to see for your self which it should say yes on hard block and once you go to the website and you do the commands then it should say no.
    Last edited by fightclub; 01-09-2011 at 02:36 AM. Reason: missing information

  3. #3
    Just burned his ISO
    Join Date
    Jan 2011

    Default Re: Error 132 in VMWare but not in Oracle VirtualBox...?

    This is a bit OT: I'm also running Oracle with the latest version of BT.
    It's a bit embarrassing, but I can't figure it out how to change the resolution to more then 800x600. Tried the xrandr command, but it only gives me 2 options and 800x600 is the higher one..

    Very grateful for some advice!


Similar Threads

  1. Error installing BT4 R2 on virtualbox
    By vze57gc8 in forum Beginners Forum
    Replies: 5
    Last Post: 03-22-2011, 12:06 PM
  2. VMware of Virtualbox
    By bgdawg in forum Beginners Forum
    Replies: 7
    Last Post: 11-30-2010, 08:20 PM
  3. virtualbox kernal error :S
    By m0j4h3d in forum Beginners Forum
    Replies: 2
    Last Post: 10-08-2010, 11:15 AM
  4. Replies: 4
    Last Post: 06-13-2010, 01:42 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts