Results 1 to 3 of 3

Thread: WiCD not responding to wireless networks

Threaded View

  1. #1
    Just burned his ISO
    Join Date
    Sep 2010

    Default WiCD not responding to wireless networks

    Hey all, ive recently updated to BT4 R2 and got madwifi drivers working for my ar5001x+ chip thru synaptic. My problem is i cant get wicd to function correctly, it detects my wired network with no problems but cant seem to scan and detect any wireless networks within my vicinity.

    It could be possible that they are hidden and i cant tell the difference because im a noob, though they can be spotted with an atheros utility in windows. I have no problems scanning them in kismet or connecting to them with airodump.

    I think the wifi has no problems being intialized when Backtrack is first loaded and the wicd icon loads on the taskbar (automatically connecting my wired connection). Ive checked the wicd log file and nothing abnormal there. In wicd's preferences ive changed the wireless interface to "ath0".

    I have tried the command: ifconfig ath0 up
    Followed by: iwlist ath0 scan
    (which returns "no scan results")

    Could it be the madwifi drivers which are fault here? Any suggestions?

    Hi again,

    Previously i had updated from Backtrack 4 to Backtrack 4 RC2. I did it through this funky command - apt-get update && apt-get upgrade

    I just downloaded a fresh ISO of Backtrack 4 RC2, installed it, and now wicd is working fine. I will try synaptic and get the madwifi drivers for my Atheros, if wicd stops functioning after that i may make a further reply in this thread.

    Ok so ive tried the madwifi drivers out by uninstalling them through synaptic, reinstalling them through a tarball i found on the wifi site. I then enter these commands -

    ifconfig ath0 up
    iwlist ath0 scan

    This is displayed: "No scan results"

    Strange thing is, when the madwifi driver is unloaded, "wlan0" (the same wifi) gets good results with the above commands.

    So because kismet, aireplay and airodump can initialize and work with the card through the madwifi drivers (ath0), im wondering what it is that these programs are telling the operating system for the wifi to kick in.

    Maybe i could use "that" to get the card "active" for wicd?

    Any ideas? Also ive heard about ath5k and ath9k maybe i could try them instead of madwifi?
    Last edited by Archangel-Amael; 01-10-2011 at 12:02 PM.

Similar Threads

  1. WICD / Changing networks
    By TLawrence in forum Beginners Forum
    Replies: 5
    Last Post: 12-30-2010, 11:30 PM
  2. no networks after using wicd
    By n1bb13 in forum Beginners Forum
    Replies: 2
    Last Post: 11-10-2010, 09:18 AM
  3. WICD not finding all networks in area.
    By BenzS550 in forum Beginners Forum
    Replies: 1
    Last Post: 05-01-2010, 06:41 AM
  4. Alfa awus036h not responding?
    By Exiiled in forum OLD Newbie Area
    Replies: 0
    Last Post: 11-15-2009, 06:52 PM
  5. Replies: 3
    Last Post: 02-26-2008, 10:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts