After downloading and burning BOTH BT4 R1 and R2, I have several issues. Graphics are fixable with a fixvesa (fatal screen not found), but I still get an error under the following :

pci_root PNP0A08:00: address space collision host bridge window [mem 0x00cc000-0c00cffff] conflicts with video ROM [mem 0x00c0000-0x000cebff].

The video card is an ATI Radeon HD 4200M (for mobility). Drivers for this exist, but there is still a collision error.

Also, my wlan0 adapter is not detected, nor is my eth0 adapter. I am restricted to this computer, and cannot seem to find any driver support for either. I went to|(4313) in order to try and download drivers for the laptop. I found that the chip was the Broadcom BCM4313 (which I am still not sure is 100% accurate, but there is not a lot of info on the laptop yet). I downloaded and followed the instructions of the tarbell, but met with no success. I still have no detected wlan0.

Any help/suggestions/fixes so I can make it to the internet would be greatly appreciated. If any other info is needed, please let me know and I will do my best to obtain it.

EDIT: I have solved the interfaces issue. A simple

sudo modprobe -r b43 ssb
sudo modprobe b43

fixed the issue (at least for a live). It detected both of my interfaces.