Results 1 to 10 of 12

Thread: Wireshark 1.2.x

Threaded View

  1. #7
    Moderator S3M73X's Avatar
    Join Date
    Feb 2010
    Posts
    103

    Arrow Re: Wireshark 1.2.x

    <note>
    do NOT try this at home.
    playing with source-code is not official supported!
    </note>

    I myself also needed this tool for a demonstration of the DECT-phone-protocol analysis.

    Just downloaded the Source of v1.2.9 and compiled it with the following options
    The Wireshark package has been configured with the following options.
    Build wireshark : yes
    Build tshark : yes
    Build capinfos : yes
    Build editcap : yes
    Build dumpcap : yes
    Build mergecap : yes
    Build text2pcap : yes
    Build idl2wrs : yes
    Build randpkt : yes
    Build dftest : yes
    Build rawshark : yes

    Install dumpcap setuid : no
    Use plugins : yes
    Use lua library : no
    Build rtp_player : yes
    Use threads : no
    Build profile binaries : no
    Use pcap library : yes
    Use zlib library : yes
    Use pcre library : no
    Use kerberos library : yes (MIT)
    Use c-ares library : no
    Use GNU ADNS library : no
    Use SMI MIB library : no
    Use GNU crypto library : yes
    Use SSL crypto library : no
    Use IPv6 name resolution : yes
    Use gnutls library : no
    Use POSIX capabilities library : no
    Use GeoIP library : no
    I am not too sure which features work since i didnt to experiments with it.
    Would be really cool if it would be added.

    Here are the Options of the current version that comes with the repos which is v1.0.3
    root@bt:~# dpkg -s wireshark | grep Depends | tr ',' '\n'
    Depends: libadns1 (>= 1.4)
    libasound2 (>> 1.0.17)
    libatk1.0-0 (>= 1.20.0)
    libc6 (>= 2.7)
    libcairo2 (>= 1.2.4)
    libcomerr2 (>= 1.01)
    libfontconfig1 (>= 2.4.0)
    libfreetype6 (>= 2.3.5)
    libgcrypt11 (>= 1.4.0)
    libglib2.0-0 (>= 2.16.0)
    libgnutls26 (>= 2.4.0-0)
    libgtk2.0-0 (>= 2.14.1)
    libjack0 (>= 0.109.2)
    libkrb53 (>= 1.6.dfsg.2)
    liblua5.1-0
    libpango1.0-0 (>= 1.21.6)
    libpcap0.8 (>= 0.9.3-1)
    libpcre3 (>= 7.4)
    libpixman-1-0
    libpng12-0 (>= 1.2.13-4)
    libportaudio2
    libtasn1-3 (>= 0.3.4)
    libx11-6
    libxcb-render-util0
    libxcb-render0
    libxcb1
    libxrender1
    wireshark-common (= 1.0.3-1ubuntu2.2)
    zlib1g (>= 1:1.1.4)
    edit:
    well DECT-protocoll support seems to be buggy ... at least with my dumps.
    allready informed the wireshark-devs
    Last edited by S3M73X; 07-15-2010 at 08:14 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •