Results 1 to 4 of 4

Thread: Nmap over pptp vpn

  1. #1
    Junior Member
    Join Date
    Jul 2009

    Default Nmap over pptp vpn

    Good Afternoon,

    I'm having a bit of a problem running nmap over my VPN. We have 20 locations over 21 subnets.

    Each is a class C (/24) network and they're all interfaced through routes on the RAS server and the local machines. I'm using kvpnc to access my vpn and the routes are setup correctly. I can remote manage every device on the network without an issue (phones, printers, pc's); and I can see them all with both ipscan and nbtscan.

    All manual pings come back correctly, that is, if I ping a dead host it does not respond but a live host will respond.

    When I run nmap: nmap -sP it tells me every host is up; including .0 & .255.

    My local interface is eth0 @
    My VPN tunnel interface is ppp0 @

    Output from nmap --iflist looks correct

    lo (lo) loopback up
    eth0 (eth0) ethernet up 00:16:76:6D:C5:94
    ppp0 (ppp0) point2point up

    Any idea's?


  2. #2
    Super Moderator Archangel-Amael's Avatar
    Join Date
    Jan 2010

    Default Re: Nmap over pptp vpn

    Nmap has plenty of documentation as well as a mailing list. It would be wise for you to ask there. They are the experts on it.
    To be successful here you should read all of the following.
    If you are new to Back|Track
    Back|Track Wiki
    Failure to do so will probably get your threads deleted or worse.

  3. #3
    Junior Member
    Join Date
    Aug 2010

    Default Re: Nmap over pptp vpn

    Only thing I can see there is that maybe you need to specify which interface to send the packets from.

    nmap -sP -e ppp0

    Try that and see the output, Im not too sure what the -sP does, could you tell me please? I tried to google a lil now and couldnt find it.

    Hope this helps

  4. #4
    Senior Member iproute's Avatar
    Join Date
    Jan 2010
    Midwest, USA

    Default Re: Nmap over pptp vpn

    -sP is ping only. I usually am only scanning one class C subnet. But I usually use maybe try that range type notation rather than CIDR.

Similar Threads

  1. [Video] Cracking VPNs (asleap and THC-pptp-bruter)
    By g0tmi1k in forum BackTrack Videos
    Replies: 20
    Last Post: 04-30-2011, 09:05 AM
  2. Problem connecting to PPTP server
    By sagarbelure in forum Beginners Forum
    Replies: 4
    Last Post: 12-07-2010, 02:29 PM
  3. [Video] Cracking VPNs (asleap and THC-pptp-bruter)
    By imported_g0tmi1k in forum OLD BackTrack 4 Howto
    Replies: 0
    Last Post: 03-19-2010, 11:18 AM
  4. Creating a VPN (pptp) connecting to internet with the BackTrack 3..
    By -->:[HazeR]:<-- in forum OLD Newbie Area
    Replies: 1
    Last Post: 12-29-2008, 10:18 AM
  5. Anyone install a PPTP client in BT2?
    By pjmcgarvey in forum OLD BackTrack v2.0 Final
    Replies: 9
    Last Post: 02-02-2008, 03:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts