Results 1 to 3 of 3

Thread: Tor + Privoxy + Torbutton / Tor + Polipo + Torbutton configuration nightmare.

  1. #1
    Just burned his ISO
    Join Date
    Dec 2010

    Thumbs down Tor + Privoxy + Torbutton / Tor + Polipo + Torbutton configuration nightmare.

    Alright, I'm new to Backtrack, and Linux in general. However, I've google'd until my eyes bled, read the FAQ and rules, and can't seem to get this problem solved.

    All I seem to get out of TOR with Privoxy is socks4a-forward errors, and with Polipo I just get TTL expired errors. When installing or configuring, I get no errors. Everything seems to "go in" just fine.

    Threads I have read:
    Backtrack .. and TOR .. you dont say!
    Configuring tor in BackTrack 4
    Privoxy works, Tor doesn't. <- Poster's problem "magically" went away...
    Problems with Tor and Privoxy....
    Installing Tor and Privoxy
    And more...

    Things I have done:
    Followed all scripts/codes/advice verbatim (updated to reflect dead links)
    Verified correct system time
    Edited privoxy.conf file appropriately
    Tried updated versions of TOR/Privoxy/Torbutton
    Checked hosts.allow and hosts.deny
    Restarted Tor and Privoxy/Polipo
    Downloaded working sample polipo.conf
    Tried running "install-less" tor browser bundle for GNU/Linux <-- doesn't work at all.

    All I want is to be able to browse TOR from a non-persistent live cd, so I don't have to go super paranoid mode and run it from a windows virtual machine on a ramdisk :/

    Any pointers would be appreciated.

  2. #2
    Just burned his ISO
    Join Date
    Feb 2010

    Default Re: Tor + Privoxy + Torbutton / Tor + Polipo + Torbutton configuration nightmare.

    hey.. tried tor and privoxy a few days ago.. this is the way it works for me
    1.sudo apt-get install tor privoxy
    2.edit the /etc/privoxy/config

    3. For bash tools i edited --> /profile/.bashrc

    4. start the daeomons -->/etc/init.d/privoxy start && /etc/init.d/tor start
    5. 2 use in firefox --> set connections settings "Manual proxy configuration" port 8118

    maybe this will help you further ; )

    ..h43z --blog

  3. #3
    Just burned his ISO
    Join Date
    Dec 2010

    Default Problem solved

    Well, it took long enough, but I've finally figured out the problem. For some odd reason, I have to set my system time 5 hours into the future for TOR to work. I suspect that my time is being configured properly, but something isn't properly set with regards to my time zone. Also, I rather stupidly spelled "forward" as "foward" in the config file.

    So here's the EASY way:

    1. Open a console and copy+paste these
    sudo echo "forward-socks4a / ." >> /etc/privoxy/config
    sudo /etc/init.d/privoxy restart && /etc/init.d/tor restart
    3. In Firefox/Iceweasel set your proxy settings manually
    HTTP =
    SSL =
    SOCKSv4 =

    If TOR still does not connect without an apparent reason, do THIS:

    1. Download the Vidalia source code (not required, but useful for troubleshooting)
    2. Extract the compressed files
    3. Follow the three commands listed in the INSTALL file that will be in the extracted folder to build and install vidalia
    4. run vidalia
    5. click "Messages" (bottom left on the GUI)
    6. see if it tells you your clock is set improperly. It will tell you the offset in seconds
    7. set your time according to the offset. A quick google search will reveal some console commands to do this. If the resulting time is in the next day, remember to increment/decrement the day appropriately.
    8. TOR should be working
    9. ???
    10. PROFIT

    Once you know the offset, it obviously won't be necessary to download vidalia anymore. The only thing to remember will be the offset, and the Linux date commands.

    Special thanks to Haez for at least attempting to help

Similar Threads

  1. Plz help me with my broadcom nightmare
    By Oblivion_Zero in forum Beginners Forum
    Replies: 4
    Last Post: 03-18-2010, 03:25 PM
  2. Wireless Nightmare!
    By unix_r00ter in forum OLD Wireless
    Replies: 5
    Last Post: 08-23-2008, 08:10 PM
  3. Nightmare with HDD install. Spent all day trying to work it out.
    By imported_ecsployt in forum OLD BT3beta General
    Replies: 6
    Last Post: 12-16-2007, 06:24 AM
  4. Torbutton Not working؟؟
    By AG-Spider in forum OLD Newbie Area
    Replies: 12
    Last Post: 06-25-2007, 06:17 PM
  5. Replies: 0
    Last Post: 06-02-2007, 10:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts