Results 1 to 3 of 3

Thread: BT4 R1 - can't MAKEDEV

  1. #1
    Just burned his ISO
    Join Date
    Nov 2010

    Angry BT4 R1 - can't MAKEDEV

    I have BT4 R1 installed to harddisk and am logged in as root. I tried to install the xawtv package and got error messages that it was unable to create the video0 and vbi0 devices. I tried to manually create them with "MAKEDEV video" which creates all the v4l devices. It failed saying the filesystem is read only. wtf? What can I do? Is this a BT release issue or an underlying ubuntu "feature"?

  2. #2
    Administrator sickness's Avatar
    Join Date
    Jan 2010
    Behind the screen.

    Default Re: BT4 R1 - can't MAKEDEV

    You could start by giving us more details, like the issued commands and their exact output, the exact error message and so on.
    Back|track giving machine guns to monkeys since 2007 !

    Do not read the Wiki, most your questions will not be answered there !
    Do not take a look at the: Forum Rules !

  3. #3
    Just burned his ISO
    Join Date
    Nov 2010

    Default Re: BT4 R1 - can't MAKEDEV

    I tried:

    apt-get install xawtv

    Sorry, I didn't try to run it again as the package actually did install except for the failing MAKEDEV script that came with it. Here is what mount said:

    root@bt:~# mount
    /dev/hda2 on / type ext3 (rw,relatime,errors=remount-ro)
    tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
    /proc on /proc type proc (rw,noexec,nosuid,nodev)
    sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
    varrun on /var/run type tmpfs (rw,nosuid,mode=0755)
    varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
    udev on /dev type tmpfs (rw,mode=0755)
    tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
    devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
    fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)

    I don't see any read-only's here! Anyway, the next day (computer was turned off) I was unable to recreate the problem and I was able to run the MAKEDEV script successfully. At this point there isn't any way to figure out what happened to make the system think that particular filesystem (which was NOT identified in the error messages) suddenly became read-only. Rebooting seems to have cured it.

    I can understand why you don't have any multimedia goodies in Back|Track, but it looks like I'm going to be using it a lot and I'd like to have my TV card working. I see the bttv and related drivers in the /usr/src/... sources but not in /lib/modules/2.6.34/kernel/drivers/... Can you point me to a HowTo or tutorial about compiling and installing them?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts