Results 1 to 2 of 2

Thread: failed to start X server upon install from live-cd (search didnt help)

  1. #1
    Just burned his ISO
    Join Date
    Nov 2010

    Default failed to start X server upon install from live-cd (search didnt help)

    Hello everyone.

    I am not a Linux guru but I have some experience with Suse and Ubuntu. I am trying to set up bt4 r2 on Samsung nc20 notebook and ran in obviously known issue with X server.

    Trying to start X server with startx leaves me with this:

    X: warning; process set to priority -1 instead of requested priority 0
    X.Org X Server 1.5.2
    (EE) Failed to load module "type1" (module does not exist, 0)
    0: /usr/bin/X11/X(xf86SigHandler+0x79) [0x80c3019]
    1: [0xffffe400]
    2: /usr/lib/xorg/modules// [0xb734193a]
    3: /usr/lib/xorg/modules// [0xb73448df]
    4: /usr/lib/xorg/modules// [0xb734da95]
    5: /usr/lib/xorg/modules// [0xb7358d3b]
    6: /usr/lib/xorg/modules// [0xb73438a5]
    7: /usr/lib/xorg/modules// [0xb73602cb]
    8: /usr/lib/xorg/modules// [0xb73620db]
    9: /usr/lib/xorg/modules/drivers// [0xb7388693]
    10: /usr/bin/X11/X(InitOutput+0x96f) [0x80aac9f]
    11: /usr/bin/X11/X(main+0x279) [0x8071b19]
    12: /lib/tls/i686/cmov/ [0xb74aebd6]
    13: /usr/bin/X11/X() [0x8071101]
    Saw signal 11. Server aborting.
    giving up.
    xinit: Connection refused (errno 111): unable to connect to X Server
    xinit: No such process (errno 3): Server error.

    i have tried fixvesa right after reboot. It has copied xorg.conf-vesa to xorg.conf and didnt help. startx leaves me with same error.

    I have tried to config xorg.conf manualy by adding recomendet resolution for my notebook which is 1280x800 even though it can handle 1024x800 but it didnt help anyway.

    i have been googling for "x server errno 111 3" and "Saw signal 11" but couldt find anything that i havent tried already.

    Neither i could find anything new by searching these forums.

    I still hope someone can help me out or point me into the right direction. Help is much appretiated.

    gratitude in advance

    excuese me for double post

    ive solved the problem on my own while waiting for answers. Hope it helps others...

    this worked for me:

    Xorg -configure
    right after booting from live-cd

    it will create a new config file in your root folder. Next step, copy it to your X11 folder

    cp /etc/X11/xorg.conf
    then go ahead with startx
    Last edited by Archangel-Amael; 11-30-2010 at 08:24 PM.

  2. #2
    Join Date
    Jun 2009

    Default Re: failed to start X server upon install from live-cd (search didnt help)

    Dude, you just solved my problem too. I couldn't get mine resized to 1152x870 (custom resolution for my Mac) and rewriting the xorg file with Xorg -configure apparently detected all the drivers again and now I can resize properly. I have spent like two effing days trying to figure this out. Thanks!!!!

Similar Threads

  1. Nvidia driver NOT working, failed to start X session
    By jack0m in forum Beginners Forum
    Replies: 9
    Last Post: 07-02-2010, 02:30 PM
  2. X server start
    By generaluser123 in forum Beginners Forum
    Replies: 1
    Last Post: 01-20-2010, 03:33 AM
  3. Fatal Server Error: AddScreen/ScreenInit failed for driver 0
    By blueteeth in forum OLD BT4beta Bugs and Fixes
    Replies: 5
    Last Post: 03-14-2009, 04:42 PM
  4. apache server won't start
    By thetom in forum OLD BT3final Bugs and Fixes
    Replies: 7
    Last Post: 07-26-2008, 12:29 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts