I recently installed Backtrack 4 R2 to my eeepc 701 4G. My hardware is:

Asus eeePC 701 4G
Atheros AR5001 (built in wireless)
Alfa AWUS036H 1Mw (usb external)

My problem is with airbase-ng, I run it as such:

airmon-ng start wlan0
airbase-ng -c 1 -e test mon0

It starts up airbase-ng and it tells me it started.
To make sure everything is working I start up the other wireless card (Atheros) in monitor mode, do a tcpdump, and grep my SSID; which shows me its broadcasting correctly. It seems everything is working so I try to scan for my soft AP from another computer (Windows), and it only detects an empty SSID but on the same channel.

I then run wireshark on the Atheros card and capture the beacons (being transmitted by my soft AP), this time noticing that there is another beacon that is transmitted from the same BSSID (my soft AP) that is empty. Wireshark shows this as SSID="Broadcast".

I'm relatively sure that not being able to connect from the other PC is related to this issue. Why is airbase-ng even transmitting an empty SSID Beacon?

I've tried both the rtl8187/mac80211 and the r8187/ieee80211 drivers as per these instructions:

Rtl8187 vs r8187 - BackTrack Linux

Is there anything I can do about this issue?

Also, I've noticed that Backtrack 4 R2 says that the aircrack-ng suite installed is v1.1 r1816 from this output:

#apt-cache policy aircrack-ng

Installed: 1.1-r1816-bt0
Candidate: 1.1-r1816-bt0
Version table:
*** 1.1-r1816-bt0 0
500 SUN Backtrack Linux Repository pwnsauce/microverse Packages
100 /var/lib/dpkg/status

However, running aircrack-ng or any other of the tools shows a version number of v1.1 r1738
Not sure what is happening here, if anyone can explain?