Results 1 to 2 of 2

Thread: Still no handshake on Linksys router

  1. #1
    Just burned his ISO
    Join Date
    Nov 2010

    Default Still no handshake on Linksys router

    In my previous post I said that I tried to break my 2 networks:
    This is very weird and I have no more ideas how to resolve my problem. Today Ive tried to broke two networks with PSK keys active on their security. On one I gave WPA2 AES and on the other one I set up WPA TKIP . For cracking procedures I used Alfa AWUS036H (500mW) and backtrack 3 on VMware machine. There was no problem to get a handshake (and then password ofc) from AES-secured network on my Edimax router, but I wasnt able to get a handshake from Linksys router (with WPA TKIP security) on "DeAuth mode". And of course everytime when I sent a DeAuth packet I got an info like:
    "Sending 64 directed DeAuth STMAC: [] [3/15 ACKs]" with simmilar numbers of responding packets and ACK's. There were quite good signals in both situations. PWR rate was about 35 on Linksys and 25-30 on connected client and about 50 on Edimax - 40 on client (Routers are located on different floors in my house).
    I've tried to check .cap files with Wireshark and then i realized some strange thing. I had no get even one EAPOL packet from Linksys router... when I sent DeAuth packet, client just made a REASSOCIACION with the AP without HandShake o_O And it happens every time. Do u know the reason of that and how to get a damn handshake by using DeAuth packet? Does Linksys routers have some different reassociation procedure, couse I have no reason to explain that.

    Take a look at wireshark logs :
    That was in backtrack 3, so I upgraded backtrack to 4 R1 version, but it hasnt changed anything except that now when Im disconecting the client I get:
    Sending 64 directed DeAuth STMAC: [] [53/63 ACKs] (and simmilar very high numbers). But still somehow there is no handshake at all !!
    Every times it looks like here:

    There is Authentication request then response, next REassociation request and response... all time without 4-way handshake, there is no even 1 EAPOL packet !
    What is the reason of that? Does Linksys has some different association procedure? Or I have to do smth else ? I havent seen anything like this before so Im very interesting about your opinions

  2. #2
    Just burned his ISO
    Join Date
    Nov 2010

    Default Re: Still no handshake on Linksys router

    I found very simmilar topic on Italian Community :

    It seems that some Linksys routers have implemented code which protects packet transmission against attackers using DeAuth to get a handshake. Good reason to buy them if u wanna feel a bit more safe

Similar Threads

  1. Handshake linksys
    By PushorPop in forum Angolo Wireless
    Replies: 7
    Last Post: 11-24-2010, 10:46 PM
  2. aircrack-ng on linksys router..
    By blackroselt in forum OLD Wireless
    Replies: 8
    Last Post: 07-06-2009, 10:43 AM
  3. Trying to bruteforce my linksys wireless router
    By drakoth777 in forum OLD Pentesting
    Replies: 5
    Last Post: 05-11-2009, 02:30 PM
  4. Linksys Router
    By mhc7791 in forum OLD Newbie Area
    Replies: 2
    Last Post: 10-10-2008, 07:33 PM
  5. LINKSYS WUSB54GC (like router)
    By g3n0c1d3 in forum OLD Newbie Area
    Replies: 0
    Last Post: 08-08-2008, 12:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts