Results 1 to 1 of 1

Thread: Metasploit Browser_autopwn module error, need help

  1. #1
    Senior Member cgelici's Avatar
    Join Date
    Feb 2010

    Default Metasploit Browser_autopwn module error, need help


    I wanted to ask about a problem I am having with the browser_autopwn module. I set all the options correcty and chose meterpreter/reverse_tcp payload, but whenever I run it I get all errors regarding the lib folder. It ends with * Cleaning up exploits. And it stays like that.

    msf auxiliary(browser_autopwn) > run[*] Auxiliary module execution completed

    [-] Auxiliary failed: ActiveRecord::StatementInvalid SQLite3::SQLException: library routine called out of sequence: SELECT * FROM "workspaces" WHERE ("workspaces"."name" = 'default') LIMIT 1
    [-] Call stack:
    [-] /opt/metasploit3/msf3/lib/active_record/connection_adapters/abstract_adapter.rb:219:in `rescue in log'
    [-] /opt/metasploit3/msf3/lib/active_record/connection_adapters/abstract_adapter.rb:202:in `log'
    [-] /opt/metasploit3/msf3/lib/active_record/connection_adapters/sqlite_adapter.rb:172:in `block in execute'
    [-] /opt/metasploit3/msf3/lib/active_record/connection_adapters/sqlite_adapter.rb:417:in `catch_schema_changes'
    [-] /opt/metasploit3/msf3/lib/active_record/connection_adapters/sqlite_adapter.rb:172:in `execute'
    [-] /opt/metasploit3/msf3/lib/active_record/connection_adapters/sqlite_adapter.rb:320:in `select'
    [-] /opt/metasploit3/msf3/lib/active_record/connection_adapters/abstract/database_statements.rb:7:in `select_all'
    [-] /opt/metasploit3/msf3/lib/active_record/connection_adapters/abstract/query_cache.rb:62:in `select_all_with_query_cache'
    [-] /opt/metasploit3/msf3/lib/active_record/base.rb:661:in `find_by_sql'
    [-] /opt/metasploit3/msf3/lib/active_record/base.rb:1548:in `find_every'
    [-] /opt/metasploit3/msf3/lib/active_record/base.rb:1505:in `find_initial'
    [-] /opt/metasploit3/msf3/lib/active_record/base.rb:613:in `find'
    [-] /opt/metasploit3/msf3/lib/msf/core/db_objects.rb:30:in `find'
    [-] /opt/metasploit3/msf3/lib/active_record/base.rb:1900:in `find_by_name'
    [-] /opt/metasploit3/msf3/lib/msf/core/db.rb:149:in `find_workspace'
    [-] /opt/metasploit3/msf3/lib/msf/core/db_manager.rb:253:in `workspace'
    [-] /opt/metasploit3/msf3/lib/msf/core/module.rb:338:in `workspace'
    [-] /opt/metasploit3/msf3/lib/msf/core/framework.rb:226:in `module_event'
    [-] /opt/metasploit3/msf3/lib/msf/core/framework.rb:240:in `on_module_run'
    [-] /opt/metasploit3/msf3/lib/msf/core/event_dispatcher.rb:186:in `block in method_missing'
    [-] /opt/metasploit3/msf3/lib/msf/core/event_dispatcher.rb:184:in `each'
    [-] /opt/metasploit3/msf3/lib/msf/core/event_dispatcher.rb:184:in `method_missing'
    [*] Cleaning up exploits...

    Can anyone help me solve this ? Or point me in the right direction at least ?

    Thank you

    Solved it.
    Massive n00b error, sorry for inconvenience.
    Had to start apache server first, what can I say, I'm just beginning !
    Last edited by Archangel-Amael; 11-27-2010 at 10:21 PM.

Similar Threads

  1. Metasploit auxilary file_autopwn module - Video Tutorial
    By brtw2003 in forum BackTrack Videos
    Replies: 5
    Last Post: 03-13-2010, 11:20 AM
  2. Replies: 1
    Last Post: 01-21-2010, 07:46 PM
  3. browser_autopwn help
    By [d0xx] in forum OLD Newbie Area
    Replies: 0
    Last Post: 12-28-2009, 07:19 PM
  4. Metasploit IE7 memory corruption module
    By jake2891 in forum OLD Newbie Area
    Replies: 2
    Last Post: 12-12-2009, 07:01 PM
  5. Metasploit 3.2 - How to add a module
    By torin in forum OLD Newbie Area
    Replies: 2
    Last Post: 04-23-2009, 02:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts