Results 1 to 3 of 3

Thread: BT4 R1 Wireless Drivers

  1. #1
    Just burned his ISO
    Join Date
    Dec 2007

    Default BT4 R1 Wireless Drivers

    This one is for the experts...

    I'm a big fan of BT - have used it as my main desktop since BT2 and have contributed to the developers in the past...

    Recently installed BT4R1 and am trying to get injection working with various cards... so far I've tested:
    - Iwlagn
    - RT73
    - ZD1211
    - RTL8187

    IWLAGN and RT73 worked "out of the box"... until I tried to fix the other drivers.

    ZD1211 requires a patch to compat-wireless and reinstall... unfortunately the current compat-wireless trunk has the dreaded monitor-mode channel setting bug, which I am yet to resolve. This broke the other drivers as well.

    The 8187 reportedly requires a switch to the r8187 driver... the r8187 driver included with BT4R1 would load but not connect in managed mode or receive packets in monitor mode. I attempted to update (with the r8187-drivers package), which puts a non-compatible module under a module tree, and of course that kernel is not included in BT4R1. Attempts to recompile the r8187 driver have not been successful thusfar.

    So a few questions:

    Is the compat-wireless source included with R1 (2010-07-10) already patched appropriately for injection with the various drivers?

    Is that source the same as the compiled drivers (iwlagn, zd1211rw, rt73) provided with BT4R1?

    Does anyone have a good idea how to fix the R8187 driver? (or the RTL8187 if there's a way?) I've read the forums extensively on this and haven't found a good answer yet.

    I am continuing to work on all of this - if I find a solution I will post it here.

    In the meantime: can someone point me in the right direction if there is a good solution to these issues?

  2. #2
    Just burned his ISO
    Join Date
    Dec 2007

    Default Re: BT4 R1 Wireless Drivers

    OK: some follow up...

    I booted BT4R1 direct from USB on a different machine (eeeBox, Atom N270) and tested several wireless cards for injection... Results were very interesting.

    Atheros 9170 and ZD1211 injected "out of the box" - Atheros had worked on another machine (Latitude 6410) but ZD1211 didn't.

    RT73, and RTL8187 passed the "aireplay-ng -9 mon0" test but didn't actually inject on my test network, at least not so far.

    RT2800 does not pass "aireplay-ng -9" with out-of-the-box R1 driver.
    A fresh boot was needed between the tests to get the drivers to run correctly.

    Apparently success is somewhat dependent on the hardware platform.

    Updates (using the tool posted here, as well as "apt-get upgrade", etc, as well as recompiling from the latest sources, break many of the drivers that work on a "fresh" install.

    So another question: other than manually extracting from the stock image, is there a way to easily return drivers to their original "out of the box" versions?

    No amount of patching and recompiling (either with the compat-wireless version supplied with R1 or later versions) will solve the "channel -1" bug in aireplay-ng - so far.

  3. #3
    Just burned his ISO
    Join Date
    Dec 2007

    Default Re: BT4 R1 Wireless Drivers

    The latest:

    Got all the wireless cards to inject: atheros, iwlagn, rt73, zd1211, rtl8187, and rt2800 on the Latitude 6410

    Patched the most recent compat-wireless snapshot (11-07-2010) with code from here:

    ... but RTL8187 would not work at all with that snapshot. Replaced that one driver with the previous version, which did the trick.

    Apparently injection is heavily driver snapshot dependent as well as hardware dependent.

    Compat-wireless snapshot from last week (11-03-2010) would not accept all the patches (particularly the "channel -1" fix above) and would not inject once compiled.

    We need a better system for keeping up with wireless drivers - it was pure trial-and-error to find ones that would load, run, and inject reliably. The various update schemes available (mostly based on apt) break more than they fix.

    Next step is to try to duplicate the same feat on a desktop machine.

    Also: I'm sorry to say it but Ubuntu is a mess. Backtrack is now probably the best version of Ubuntu available but in general Ubuntu is absolutely full of bugs in critical components and the apt system, which is supposed to make it easier to fix stuff, is a mess too. When BT first switched to Ubuntu, I was worried about this but thought it might make it easier to add other applications, but it really doesn't. It just wastes more time trying to fix apt. I wish there were a better distro solution overall.
    Last edited by cw5301; 11-08-2010 at 05:07 PM.

Similar Threads

  1. Wireless drivers not loading
    By pietjepuk12345 in forum Beginners Forum
    Replies: 3
    Last Post: 10-07-2010, 11:13 AM
  2. reinstalling wireless drivers
    By Nazagul in forum Beginners Forum
    Replies: 6
    Last Post: 09-19-2010, 03:45 AM
  3. Wireless NIC drivers from BT4 in other distros
    By irunwithscissors in forum Beginners Forum
    Replies: 2
    Last Post: 09-17-2010, 10:10 PM
  4. When trying to 'make' wireless drivers...
    By ghostfox1 in forum OLD BackTrack 4 General Support
    Replies: 0
    Last Post: 08-11-2009, 04:27 PM
  5. Drivers for wireless card?
    By DecoY in forum OLD Newbie Area
    Replies: 1
    Last Post: 08-02-2007, 08:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts